PnCConf stepper test tune works but changes are not accepted by Axis gui

More
26 Jan 2021 16:24 #196633 by Captainjack
I have been running Linuxcnc on my milling machine for over 2 years using Mesa 5i25 and 7i76 cards with no problems. I recently made some changes to the Z axis counter balancing so that I could increase max velocity. I went to the stepper test tune function which worked fine and made the changes on accel and max velocity and saved them. When I restart Axis the changes are ignored. This is after restarts and rebooting. I am not confident enough to hand edit the files that PnCConf modifies. I set the whole thing up with the PnCConf wizard but now I can't seem to make changes.

Please Log in or Create an account to join the conversation.

More
26 Jan 2021 17:16 - 26 Jan 2021 17:36 #196638 by PCW
I think you are better off just editing the ini and hal files to change the required velocity
numbers ( axis and stepgen max velocity if you are using LinuxCNC 2.7, axis, joint,
and stepgen max velocity if you are using LinuxCNC 2.8 or greater)
Last edit: 26 Jan 2021 17:36 by PCW.

Please Log in or Create an account to join the conversation.

More
26 Jan 2021 20:08 #196660 by Captainjack
Problem solved! My first problem was I was editing the wrong ini file. Second, on the axis screen it has a max velocity number in inches per minute. I thought this came from the max velocity values entered for the stepper motors but it is just max jog velocity. PnCConf wizard was putting the correct values in the ini file but it did not change jog max velocity. Anyway, it is all working the way I want now. Thanks for your help.

Please Log in or Create an account to join the conversation.

Moderators: cmorley
Time to create page: 0.110 seconds
Powered by Kunena Forum