PnCConf Wizard doesn't launch

More
04 Aug 2021 12:13 #216903 by BigJohnT
All the sims for Mesa look like very old cards like 5i20 era. I don't see any for the newer cards.

JT

Please Log in or Create an account to join the conversation.

More
09 Aug 2021 01:14 #217274 by CFE
Replied by CFE on topic PnCConf Wizard doesn't launch
Hi all,

I have manually set up .ini and .hal files to create a basic machine, and I wanted to run PlasmaC/QtPlasmaC configurator. But if I read the QtPlasmaC user guide then QtPlasmaC is now setup with the PnCConf Wizard, which is the very thing that doesn't work. What am I supposed to do now ?

Cheers, Peter

Please Log in or Create an account to join the conversation.

More
13 Aug 2021 15:30 #217685 by robertspark
is pncconf working again under master / 2.9 (post python 3 
migration)

I ask from curiosity (not need) as I've seen I think Phil kindly pushing a number of updates and I'm updating and rebuilding my RIP daily and did try pncconf last night and could not get it to start.

​​​​​​​
 

Please Log in or Create an account to join the conversation.

More
13 Aug 2021 20:08 #217702 by rodw
Replied by rodw on topic PnCConf Wizard doesn't launch

is pncconf working again under master / 2.9 (post python 3 
migration)

I ask from curiosity (not need) as I've seen I think Phil kindly pushing a number of updates and I'm updating and rebuilding my RIP daily and did try pncconf last night and could not get it to start.



 

Unfortunately, Phill is not the PNCCONF developer. He said in another thread that he had spent some hours on it but gave up as he did not want to learn Glade. I spent a few minutes on it and gave up. Phil also said that he did not want to create and maintain another seperate configurator. There is a conversion tool that converts python2 to python3 quite reliably and I got rid of 1 or 2 errors but I think the real issue is the use of Glade by PNCCONF is not supported. STEPCONF is also broken. Phill, thought that would be a fairly easy fix.

Also Debian Bullseye is scheduled for release today (14th). It is based on the 5.10 kernel and includes PREEMPT_RT in its distro. Robert and I have built it and I was planning to write a how to once its released. There are no repos on buildbot for bullseye so it has to be RIP but I was able to build the debs and install LCNC to the menus that way. There is a thread documenting how to go about it in the Installing Linuxcnc section now but its a bit messy to follow as it was not written specifically as a how to.

Please Log in or Create an account to join the conversation.

More
13 Aug 2021 20:25 #217704 by robertspark
thanks Rod, I was just curious as I too was going to have a fiddle with it (pncconf)

I have been fiddling with NativeCam and trying to python3 it (there are a fair few changes with GI repository as some syntax has changed... not just the GTK or GTD but other stuff too (pixbuf got me a bit last night, but I sorted it.... I think .... it doesn't tell me off any more...)

Please Log in or Create an account to join the conversation.

More
13 Aug 2021 21:47 #217710 by cmorley
Phill is working on a pncconf branch.
It has not been pushed to master yet.

Please Log in or Create an account to join the conversation.

More
14 Aug 2021 00:37 #217718 by phillc54
I have pushed the PnCconf changes. I probably missed something but it does at least seem to build configs.

Stepconf was "fixed" several days ago.
The following user(s) said Thank You: robertspark, snowgoer540

Please Log in or Create an account to join the conversation.

More
14 Aug 2021 01:49 #217722 by rodw
Replied by rodw on topic PnCConf Wizard doesn't launch

I have pushed the PnCconf changes. I probably missed something but it does at least seem to build configs.

Stepconf was "fixed" several days ago.


NOt sure if I did something unexpected but there are a number of errors loading hostmot2. I think pncconf is stuttering...
loadrt hm2_eth board_ip="10.10.10.10, 192.168.1.121" config="num_encoders=1 num_pwmgens=0 num_stepgens=5 sserial_port_0=00xxxx, num_encoders=3 num_pwmgens=0 num_stepgens=5 sserial_port_0=00xxxx00xxxx" 

Please Log in or Create an account to join the conversation.

More
14 Aug 2021 02:19 #217725 by robertspark
thanks phill I'll give it a go

Please Log in or Create an account to join the conversation.

More
14 Aug 2021 02:26 #217727 by cmorley

I have pushed the PnCconf changes. I probably missed something but it does at least seem to build configs.

Stepconf was "fixed" several days ago.

NOt sure if I did something unexpected but there are a number of errors loading hostmot2. I think pncconf is stuttering...
loadrt hm2_eth board_ip="10.10.10.10, 192.168.1.121" config="num_encoders=1 num_pwmgens=0 num_stepgens=5 sserial_port_0=00xxxx, num_encoders=3 num_pwmgens=0 num_stepgens=5 sserial_port_0=00xxxx00xxxx" 

Did you pick two mesa cards?
could you post your pncconf file?

Please Log in or Create an account to join the conversation.

Moderators: cmorley
Time to create page: 0.092 seconds
Powered by Kunena Forum