config 6i25 & 7i77 - can't select pwm output

More
21 Jan 2022 23:42 #232705 by jpevner
Pcw:
On the configuration page, there are three fields #encoders, #pwm generators, #step/dir. I assume that I am to enter the number of each that I wish?
I have been selecting 1 for encoders, 1 for pwm, and 0 for step/dir. When hitting the accept tab, the program erases the 1 in #pwm generator and puts in a 0.

I have tried going to the SS tab and selecting an unused pwm and setting it to be  axis "x". This doesn't seem to change anything.

Glad to hear that PNC conf  doesn't need anything connected, though I do have the 7i77 connected to the 6i25

This could certainly be just something stupidly obvious that I am not picking up on.

Jon P.

Please Log in or Create an account to join the conversation.

More
21 Jan 2022 23:49 #232706 by PCW

I have tried going to the SS tab and selecting an unused pwm and setting it to be  axis "x". This doesn't seem to change anything.
 

It changes the commands created in the HALand INI files

Please Log in or Create an account to join the conversation.

More
22 Jan 2022 01:16 #232718 by jpevner
Think I get it now.
That field #pwm generators was very confusing. This doesn't seem to do anything. Anyway, I went through the process and  selected three encoders and three pwms on the appropriate tabs, one for each axis. I was able to complete and write some files which I will look at later.


Thanks for all the help.
Jon P.

Please Log in or Create an account to join the conversation.

Moderators: cmorley
Time to create page: 0.083 seconds
Powered by Kunena Forum