locale error: unsurported local setting on Raspberry Pi 4

More
30 Nov 2023 19:48 #286899 by mistolt
Hey everyone,
After using Intel Nucs for my Mill, I thought I try it on the small Raspberry Pi 4 for my Lathe.
But I encountered a Problems in the PnCConf Wizard.
Step bevor error:
Install the newest Linuxcnc Image for RP4 via Raspberry Pi Imager (No settings aplied)
Chance keyboard layout to german
sudo apt-get update
sudo apt-get install network-manager*
Change the ethernet IP Adress to 10.10.10.1
Start PnCConf Wizard
Select 7i76s
Do the first couple of pages until the page for the X-Motor comes up. (nothing special there)
Input a Value into the stepper Scale
Test the Stepper= it works.
Then the following error occurs.
 
I can´t read anything into the error message

Since than i tried:
My 7i76e: Same error
A Intel Nuc from my Mill: No Error, works just fine
Reinstall Linuxcnc: No change
Chance Raspberry Pi: No change
Searched the forum: Didn´t find my specific problem

And now I hope, you can help me with my error

 
Attachments:

Please Log in or Create an account to join the conversation.

More
30 Nov 2023 20:59 #286904 by tommylight
Try setting locale to UTF_8 then run PncConf again.
The following user(s) said Thank You: mistolt

Please Log in or Create an account to join the conversation.

More
01 Dec 2023 08:23 #286946 by mistolt
I´m not sure, what to do.
I checked the locales and everything seems fine.
 
(don´t mind my tipo)
Attachments:

Please Log in or Create an account to join the conversation.

More
01 Dec 2023 22:20 #287000 by rodw
On the pi, please type
sudo menu-config
to set locale
The following user(s) said Thank You: mistolt

Please Log in or Create an account to join the conversation.

More
02 Dec 2023 20:57 - 02 Dec 2023 20:58 #287049 by mistolt
Thank you for your help.
I brute forced it, by activating all locals. (After figuring out, that I have to use the "Spacebar" to activate the different settings xD)
It works, but I will try which one is the problem.
Next try I only activated only the de_ an en_ ones, which also worked
I´ll post the right one in this thread in the future.
Last edit: 02 Dec 2023 20:58 by mistolt.

Please Log in or Create an account to join the conversation.

More
03 Dec 2023 21:07 #287140 by mistolt
The missing local was the:
en_US.UTF-8 UTF-8

I only needed this one activated. Now everything works.

Please Log in or Create an account to join the conversation.

Moderators: cmorley
Time to create page: 0.133 seconds
Powered by Kunena Forum