LinuxCNC PNCconf error on RasPi 4

More
11 Jan 2024 20:01 #290451 by Hartmut.Seitter
Hello,I am running LinuxCNC (2.72) on a intel pc for some years successful. Now the harddrive on the intel pc is broken and I would like to run LinuxCNC on a RasPi 4.I created the raspi image and I booted the raspi and now I am trying to create the configuration using PNCconf.When I try to finish the X Motor settings I get an error PNCConf encountered an Error ......locale.Error: unsupported locale settingCan anybody help me to fix this problem, so that I can configure my cnc on a raspi 4, please. (I cannot use the config files from the older version, because there are some changes in the config file /s, and I am pretty sure I have to create now config files for version 2.9.2.I am using a Mesa Card 7i76e (which was/is successfully used by my old config)Any help is highly appreciatedBest regards Hartmut
   
Attachments:

Please Log in or Create an account to join the conversation.

More
11 Jan 2024 20:58 #290454 by tommylight
Change the locale settings to UTF-8, search google for how to do that on Debian, any Debian.
P.S.
I have no idea how to do that as i never needed it, but that is the issue as stated at the end of the error report.

Please Log in or Create an account to join the conversation.

More
12 Jan 2024 08:12 #290478 by Hartmut.Seitter
Many thanks for the reply - changing locals to en_GB.UTF-8 using the cmd sudo dpkg-reconfigure locales solved this problem. Hope I have now fix all stuff to get linuxcnc running on raspi.

Many thx and best regarsd
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

Moderators: cmorley
Time to create page: 2.872 seconds
Powered by Kunena Forum