stepgen by pncconf

More
27 Mar 2011 22:28 - 27 Mar 2011 22:29 #8174 by andradela
stepgen by pncconf was created by andradela
Hello guys, today I start some tests with my 7i43's card, i create a simple project with 3 stepgen only, so when i use test/tune/axis i have no signal in the 7i43 output, but when I use the sample "hm2 stepper" it works. Why my project doesn't work?
Last edit: 27 Mar 2011 22:29 by andradela.

Please Log in or Create an account to join the conversation.

More
27 Mar 2011 23:19 #8177 by cmorley
Replied by cmorley on topic Re:stepgen by pncconf
What version of EMC are you using?
Can you post your files?

Please Log in or Create an account to join the conversation.

More
28 Mar 2011 21:38 #8231 by andradela
Replied by andradela on topic Re:stepgen by pncconf
My emc version is 2.4.6

File Attachment:

File Name: test.gz
File Size:4 KB
Attachments:

Please Log in or Create an account to join the conversation.

More
28 Mar 2011 21:52 #8232 by cmorley
Replied by cmorley on topic Re:stepgen by pncconf
in the file teste.hal remove lines 11 and 12:
loadrt abs names=
loadrt lowpass names=
and try that.
Also could you post the pncconf file
should find it in /emc2/configs/teste.pncconf

Please Log in or Create an account to join the conversation.

More
28 Mar 2011 22:26 - 28 Mar 2011 22:27 #8233 by andradela
Replied by andradela on topic Re:stepgen by pncconf
OK follow the file teste.pncconf

File Attachment:

File Name: teste.gz
File Size:8 KB
Attachments:
Last edit: 28 Mar 2011 22:27 by andradela.

Please Log in or Create an account to join the conversation.

More
28 Mar 2011 22:29 #8234 by andradela
Replied by andradela on topic Re:stepgen by pncconf
what are these lines?

Please Log in or Create an account to join the conversation.

More
28 Mar 2011 22:36 #8235 by cmorley
Replied by cmorley on topic Re:stepgen by pncconf
absolute and lowpass components are used when displaying spindle speed in a pyvcp panel.
pncconf incorrectly added them when not needed (that why there are no names attached)
I'm pretty sure this error was found and fixed but has not been released yet.

Please Log in or Create an account to join the conversation.

More
29 Mar 2011 18:03 #8261 by andradela
Replied by andradela on topic Re:stepgen by pncconf
I removed the lines and did a test it didn't work, just works with the sample.

Please Log in or Create an account to join the conversation.

More
30 Mar 2011 00:22 #8270 by cmorley
Replied by cmorley on topic Re:stepgen by pncconf
Can you give more info.
Does EMC give an error ( if yes what is it) or is there just no output on the 7i43?

Please Log in or Create an account to join the conversation.

More
30 Mar 2011 00:30 #8271 by cmorley
Replied by cmorley on topic Re:stepgen by pncconf
hmm I checked the logs and there was another problem with the 7i43 with pncconf which had to do with the connector numbering being wrong.
can you check that your signals are not on the other connector.

Please Log in or Create an account to join the conversation.

Moderators: cmorley
Time to create page: 0.106 seconds
Powered by Kunena Forum