[Gelöst] Probleme mit der HAL Komponente „message“

More
17 Oct 2021 12:16 - 18 Oct 2021 18:29 #223374 by Arbiwei
Hallo ich habe Probleme mit der message Komponente.
Ich überwache damit einen Frequenzumrichter wenn dieser einen Fehler ausgibt geht LinuxCNC in den Not-Halt und die Meldung wird richtig ausgegeben die schalt Zustände des pin Message.triggers sind True.
Meldung wird angezeigt.
wenn ich die Maschine starte wird aber auch die Meldung angezeigt obwohl der trigger Pin beim Start false hat. Ich verstehe gerade die Logik dahinter nicht. Dachte False keine Meldung und True Meldung anzeigen. Genau so ist es in der HAL verknüpft.
Weis zufällig jemand meinen Fehler oder ist es ein Bug im LinuxCNC.

Konfiguration kann ich gerne nachreichen bin gerade aber unterwegs.
Last edit: 18 Oct 2021 18:29 by Arbiwei.

Please Log in or Create an account to join the conversation.

More
17 Oct 2021 15:04 #223386 by PCW
Ich würde vermuten, dass das an die Nachrichtenkomponente gesendete Signal möglicherweise einen anfänglichen Fehler aufweist. Sie können versuchen, eine "und"-Komponente in Reihe mit dem . hinzuzufügen
Frequenzwandlersignal, um sicherzustellen, dass das Signal bis vielleicht niedrig ist
der Maschinen-Ein-Zustand.
The following user(s) said Thank You: Arbiwei

Please Log in or Create an account to join the conversation.

More
17 Oct 2021 20:04 #223411 by Arbiwei
Ja das klingt interessant ich lese einige Zustände des Umrichters per MB2HAL aus es kann wirklich sein das ich kein eindeutigen FALSE beim trigger habe. Wie könnte man das verzögern. Eventuell mit der Edge Komponente.

Please Log in or Create an account to join the conversation.

More
17 Oct 2021 21:28 #223416 by PCW
Ich dachte an etwas Einfaches wie das Gating des Fehlers mit Machine-On, damit die Modbus-Kommunikation hergestellt wird, bevor der VFD-Status überprüft wird
The following user(s) said Thank You: Arbiwei

Please Log in or Create an account to join the conversation.

More
18 Oct 2021 18:31 #223485 by Arbiwei
Ja es überschneiden sich die Pins beim Start.
mb2hal ist noch nicht soweit 

Please Log in or Create an account to join the conversation.

Time to create page: 0.059 seconds
Powered by Kunena Forum