Homing

More
02 Nov 2022 14:17 #255786 by __Tom
Homing was created by __Tom
Hallo LinuxCnc ist Neuland für mich und ich hoffe hier ein paar Antworten zu bekommen. Ich habe eine Mesa 7i76e card alle Achsen laufen soweit ohne Probleme. Mein Problem ist die Referenzfahrt. Das Verhalten was ich habe:Starte die Referenzfahrt einer Achse manuell in meinen Fall Y.Die Referenzfahrt startet korrekt.Der Home switch schaltet:G53 wird auf 0 gestellt und die Laufrichtung der Achse ändert sich von – auf +und bleibt nicht mehr stehen. Auch nicht wenn man den Home switch erneut schaltet. Was ich mir mit meinem Einstellungen erwarte:Home switch soll angefahren werden → schaltetAchse soll ein kleines Stück zurücksetzen und erneut mit verminderten Vorschub angefahren werden. → Switch schaltet: Achse auf 0 Home Pos mit Eilgang anfahren und stehen bleiben fertig. Ich hoffe es kann mir von Euch jemand einen Tip geben was ich da falsch gemacht habe. Die INI Einstellungen:#******************************************[AXIS_Y]MAX_VELOCITY = 58.3333333333MAX_ACCELERATION = 50.0MIN_LIMIT = -0.0MAX_LIMIT = 50.0 [JOINT_1]TYPE = LINEARHOME = 1.0FERROR = 10.0MIN_FERROR = 1.0MAX_VELOCITY = 58.3333333333MAX_ACCELERATION = 50.0# The values below should be 25% larger than MAX_VELOCITY and MAX_ACCELERATION# If using BACKLASH compensation STEPGEN_MAXACCEL should be 100% larger.STEPGEN_MAXVEL = 72.92STEPGEN_MAXACCEL = 62.50P = 1000.0I = 0.0D = 0.0FF0 = 0.0FF1 = 1.0FF2 = 0.0BIAS = 0.0DEADBAND = 0.0MAX_OUTPUT = 0.0# these are in nanosecondsDIRSETUP = 10000DIRHOLD = 10000STEPLEN = 5000STEPSPACE = 5000STEP_SCALE = 640.0MIN_LIMIT = -0.0MAX_LIMIT = 50.0HOME_OFFSET = 3.000000HOME_SEARCH_VEL = -3.316667HOME_LATCH_VEL = -0.833333HOME_FINAL_VEL = 0.500000HOME_USE_INDEX = NOHOME_SEQUENCE = 2#****************************************** Die Hal Einstellungen: Input 08 # external input signals  # --- ALL-HOME ---net all-home <= [HMOT](CARD0).7i76.0.0.input-08-not #*******************# AXIS X JOINT 0#******************* setp pid.x.Pgain [JOINT_0]Psetp pid.x.Igain [JOINT_0]Isetp pid.x.Dgain [JOINT_0]Dsetp pid.x.bias [JOINT_0]BIASsetp pid.x.FF0 [JOINT_0]FF0setp pid.x.FF1 [JOINT_0]FF1setp pid.x.FF2 [JOINT_0]FF2setp pid.x.deadband [JOINT_0]DEADBANDsetp pid.x.maxoutput [JOINT_0]MAX_OUTPUTsetp pid.x.error-previous-target true# This setting is to limit bogus stepgen# velocity corrections caused by position# feedback sample time jitter.setp pid.x.maxerror 0.012700 net x-index-enable <=> pid.x.index-enablenet x-enable => pid.x.enablenet x-pos-cmd => pid.x.commandnet x-pos-fb => pid.x.feedbacknet x-output <= pid.x.output # Step Gen signals/setup setp [HMOT](CARD0).stepgen.02.dirsetup [JOINT_0]DIRSETUPsetp [HMOT](CARD0).stepgen.02.dirhold [JOINT_0]DIRHOLDsetp [HMOT](CARD0).stepgen.02.steplen [JOINT_0]STEPLENsetp [HMOT](CARD0).stepgen.02.stepspace [JOINT_0]STEPSPACEsetp [HMOT](CARD0).stepgen.02.position-scale [JOINT_0]STEP_SCALEsetp [HMOT](CARD0).stepgen.02.step_type 0setp [HMOT](CARD0).stepgen.02.control-type 1setp [HMOT](CARD0).stepgen.02.maxaccel [JOINT_0]STEPGEN_MAXACCELsetp [HMOT](CARD0).stepgen.02.maxvel [JOINT_0]STEPGEN_MAXVEL # ---closedloop stepper signals--- net x-pos-cmd <= joint.0.motor-pos-cmdnet x-vel-cmd <= joint.0.vel-cmdnet x-output <= [HMOT](CARD0).stepgen.02.velocity-cmdnet x-pos-fb <= [HMOT](CARD0).stepgen.02.position-fbnet x-pos-fb => joint.0.motor-pos-fbnet x-enable <= joint.0.amp-enable-outnet x-enable => [HMOT](CARD0).stepgen.02.enable # ---setup home / limit switch signals--- net all-home => joint.0.home-sw-innet x-neg-limit => joint.0.neg-lim-sw-innet x-pos-limit => joint.0.pos-lim-sw-in

Please Log in or Create an account to join the conversation.

More
02 Nov 2022 14:34 #255791 by tommylight

Please Log in or Create an account to join the conversation.

Time to create page: 0.068 seconds
Powered by Kunena Forum