Error en mecanizados....

More
22 Sep 2019 02:09 #145811 by Davidarod
Hola comunidad, desde hace unos meses me metí en este mundo de las cnc, y la verdad no paro de aprender, hace unos meses ocupaba mach3 pero me decidí a cambiar por linuxcnc con unos resultados excelentes, pero no todo es color de rosas, queriendo hacer el primer mecanizado relativamente grande, 35x28cm llega en un momento en la q la maquina se descontrola, esto ya me lo hacia con el mach3 por eso mi desicion de cambiar por linuxcnc pero veo que persiste el mismo problema, el eje Z se va mas hacia abajo ademas q el eje Y se vuelve loco y tiende a irse hacia algún lado, perdiendo el punto cero, al desconocer del tema re-configure la latencia y sigue con lo mismo, alguien me puede decir que puede ser? por que la verdad se me acabaron las ideas de por q puede ser....
desde ya muchas gracias y muy bueno el foro.
Attachments:

Please Log in or Create an account to join the conversation.

More
22 Sep 2019 14:30 #145845 by pl7i92
Replied by pl7i92 on topic Error en mecanizados....
¡Hola
¿Puede darnos los datos de su máquina ((INI, HAL))
para que podamos verlo
También sería útil la información sobre la interfaz y el hardware.

Esto ciertamente se debe solo a un valor de aceleración que se estableció demasiado alto
The following user(s) said Thank You: Davidarod

Please Log in or Create an account to join the conversation.

More
22 Sep 2019 15:02 #145856 by RobotMatic
Replied by RobotMatic on topic Error en mecanizados....
Hola. Entiendo por lo que comentas que no tenes un problema enel software de control, estas estas teniendo un problema de senal. Primer punto, estas seguramente utilizando el puerto paralelo de tu pc, la longuitud maxima no puede superar los 1,5 mtrs, por ejemplo. Otro tema es el ruido electrico que produce los motores de husillo y el tercer elemento es el calculo de esfuerzo mecanico, si tus motores son muy chicos se produce la perdida de pulso y tus ejes se van a cualquier lado. como veras hay muchos factores que pueden generar tu problema, comienza de a uno a la vez revisando.
The following user(s) said Thank You: Davidarod

Please Log in or Create an account to join the conversation.

More
29 Sep 2019 21:43 - 29 Sep 2019 21:47 #146629 by Davidarod
Replied by Davidarod on topic Error en mecanizados....
Hola antes que nada te agradezco que te tomes un tempo al contestar, debido a que la maquina es armada en forma casera, y ademas la compre de segunda mano, no tengo muchos datos necesarios para la configuracion y a eso sumale que recien estoy aprendiendo se hace mas complicado, se que los driver son los TB 6650 debido a que lo desarme los micropasos estan a 1/16 y los motores son los NEMA 24 de 3,5N y 3 amp. (por lo poco que encontré tienen 200 pasos). ya sabemos lo que paso con el problema de que el eje Z, era un problema mas mecanico q electronico, cosa que tuvimos que arreglar por eso demore en contestar en el foro, al hacer otra prueba ahora solo se despablo hace un lado, pero nos salio un problema de latencia, buscando realice la prueba de latencia de nuevo (adjunto una foto) yo tenia antes la latencia en 250000, los datos de driver timing settings (step time, step space, direction hold, direction setup) son sacados de un post de este mismo foro, debido a que nunca encontre muchos datos sobre mis drivers, tambien te adjunto los archivos que me pediste.
realmente es pero que reconfigurar la latencia este solucionado pero bueno seguire haciendo pruebas hasta que salga, lo otro que pensaba era en bajarle la velocidad al eje Y que tal vez eso tenga algo que ver.... pero bueno es una suposicion y ya veremos q pasa, desde ya muchas gracias de nuevo por tomarte el tiempo en leer todo esto.
Attachments:
Last edit: 29 Sep 2019 21:47 by Davidarod.

Please Log in or Create an account to join the conversation.

More
29 Sep 2019 21:51 #146630 by Davidarod
Replied by Davidarod on topic Error en mecanizados....
La longitud del cable es de 1.2m, ya tuve problemas con ruidos electricos y en teoria estan todos eliminados, o atenuados en su mayoria, solo hay una bomba de agura del sistema de refrigeracion q no tiene salida a tierra pero es el unico

Please Log in or Create an account to join the conversation.

More
30 Sep 2019 01:01 #146658 by RobotMatic
Replied by RobotMatic on topic Error en mecanizados....
podrias poner fotos de tu maquina, mas precisamente del ensamble de cada motor a sus ejes . y una general, tengo la impresion que tus ejes no tienen fuerza y bajando la velocidad puede llegar a ser una solucion temporaria, pero no final.

Please Log in or Create an account to join the conversation.

More
07 Apr 2020 21:18 #163102 by Alfredo
Replied by Alfredo on topic Error en mecanizados....
Si el problema del eje Y lo hace con Mach3 y con LinuxCNC. acaso tiene un problema el codigo G ?...es cierto que cuando se genera, se hace perfecto, pero en algún momento pudiste editarlo y es ahí donde perdió la secuencia?...

Please Log in or Create an account to join the conversation.

Moderators: dangercraft
Time to create page: 0.130 seconds
Powered by Kunena Forum