pas de départ de cycle

More
14 Oct 2023 15:27 #282999 by fgland
Bonsoir,
Je suis nouveau sur ce forum et sur linuxcnc. Je récupère une machine sherlinglathe. Le disque fourni est ancien(6 ans je crois) j'ai donc fait une installation sur un pc et dans une machine virtuelle(kvm) avec la dernière debian dédiée :  Debian 4.19.249-2.
J'ai choisi la configuration par machine SherlineLathe_mm qui est proposée.
Sur les deux installations, quand je lance le programme j'ai le message Pas de départ de cycle avant la prise d'origine machine. Quand je défini les axes je n'ai que X et Z ce qui est je suppose l'origine du problème.

Si je prends la configuration Sherline3Axis_mm, tout marche bien !
Comment corriger ce problème ?
Merci de votre attention
Gérard

Please Log in or Create an account to join the conversation.

More
14 Oct 2023 15:58 - 14 Oct 2023 16:03 #283000 by Aciera
Replied by Aciera on topic pas de départ de cycle
Bienvenu Gérard
Ce programme chargé est pour une machine de fraisage avec axes XYZ.
Avec un tour traditionel il y a seulement deux axes X et Z, donc dans une configuration de linuxcnc destiné pour un tour l'axe Y n'existe pas.
Ce n'est pas possible de lancer un programme destinee pour une machine XYZ avec un configuration destinee pour un tour.

[edit]
Dans le fichier 'nc_files' ce trouve un programme 'lathe_pawn.ngc' pour un tour.
Last edit: 14 Oct 2023 16:03 by Aciera.

Please Log in or Create an account to join the conversation.

More
14 Oct 2023 18:34 #283003 by fgland
Replied by fgland on topic pas de départ de cycle
Merci pour la rapidité de la réponse.
Ok pour le Z, il faut donc que je prenne 3 axes et ignorez le Z
Dans les configurations proposées

Je vais donc prendre 3 axes et ne pas utiliser le Z !
Merci, cela va ma permettre de commencer la découverte

Please Log in or Create an account to join the conversation.

Moderators: darty367
Time to create page: 0.059 seconds
Powered by Kunena Forum