Linuxcnc always wants to update my INI file

More
24 Jul 2019 08:31 #140415 by JetForMe
Every time I launch linuxcnc I get an alert with the message
The [EMC]VERSION information in your INI file indicates that your configuration needs update.

If I say "Yes" to this, I then get another alert that says
The supplied INI file is already at version 1.6 and should not need updating

(or whatever value I put in there).

If I say no, it loads normally. But the alert is annoying. What can I do to avoid this?

Please Log in or Create an account to join the conversation.

More
24 Jul 2019 09:05 #140419 by tommylight
Version should be 1.1

Please Log in or Create an account to join the conversation.

More
24 Jul 2019 16:16 #140437 by Dinuka_Shehan
Download the latest version.

Please Log in or Create an account to join the conversation.

More
24 Jul 2019 18:24 - 24 Jul 2019 18:26 #140450 by bevins
There's a Version=X in ini file I think. This needs to be changed to something, I forgot, Andy told me one time when I was having the same issue.

EDIT\ Change the line in your ini to read version = 1.1 in [EMC] section. As Todd said...kinda...lol
Last edit: 24 Jul 2019 18:26 by bevins.

Please Log in or Create an account to join the conversation.

More
24 Jul 2019 19:50 - 24 Jul 2019 19:51 #140464 by Todd Zuercher
I don't remember saying anything?

But if your running Linuxcnc 2.8 or Master (2.9-pre) The ini file as a version line near the beginning. When you import an older configuration Linuxcnc uses that version number to decide if it should run the update conversion script on your configuration or not. (for converting to the new Joints/Axis configuration used in 2.8+.)
Last edit: 24 Jul 2019 19:51 by Todd Zuercher.
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
24 Jul 2019 21:39 #140478 by tommylight

Todd Zuercher wrote: I don't remember saying anything?


I think he was refering at me, sorry for disturbing you. :)

Please Log in or Create an account to join the conversation.

More
24 Jul 2019 22:44 #140481 by bevins
oops, I meant Tommy

Please Log in or Create an account to join the conversation.

More
25 Jul 2019 00:42 #140486 by JetForMe

tommylight wrote: Version should be 1.1


According to the docs : "It’s a good idea to change this number each time you revise your file."

I only bumped it because I was getting the warning before. After bumping it, it went away. Then it came back so I bumped it again.

Please Log in or Create an account to join the conversation.

More
25 Jul 2019 01:08 #140490 by tommylight
I have not yet done much testing on 2.9, but 2.8 requires that to be 1.1
Anything else and it will try to run the wizard to change the version.
The following user(s) said Thank You: JetForMe

Please Log in or Create an account to join the conversation.

More
25 Jul 2019 01:53 #140492 by JetForMe
So, it sounds like the documentation is incorrect, then.

Please Log in or Create an account to join the conversation.

Time to create page: 0.125 seconds
Powered by Kunena Forum