Linuxcnc always wants to update my INI file

More
25 Jul 2019 07:49 #140512 by Clive S

JetForMe wrote: So, it sounds like the documentation is incorrect, then.


The docs were probably written before the configuration tools were made
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
25 Jul 2019 12:39 #140525 by Todd Zuercher
Yes, the docs are incorrect, and should be updated.

Please Log in or Create an account to join the conversation.

More
25 Jul 2019 20:03 #140561 by JetForMe

tommylight wrote: I have not yet done much testing on 2.9, but 2.8 requires that to be 1.1
Anything else and it will try to run the wizard to change the version.


Thanks, Tommy. 1.1 works in 2.9, too. I had 1.1, at some point it complained, but now it's not complaining.
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
25 Jul 2019 20:19 #140564 by tommylight
You are welcomed.

Please Log in or Create an account to join the conversation.

More
26 Jul 2019 12:11 #140646 by BigJohnT
It's a good practice to use the documents for the branch your using.

linuxcnc.org/docs/2.8/html/config/ini-config.html#_emc_section

JT

Please Log in or Create an account to join the conversation.

More
27 Jul 2019 00:17 #140704 by JetForMe
I'm using 2.9, and those docs say "It’s a good idea to change this number each time you revise your file."

Please Log in or Create an account to join the conversation.

More
27 Jul 2019 11:34 - 27 Jul 2019 11:43 #140743 by BigJohnT
The 2.8 and 2.9 docs say:
VERSION = 1.1 - The version number for the configuration. Any value other than 1.1 will cause the configuration checker to run and try to update the configuration to the new style joint axes type of configuration.

You might need to refresh your browser with Ctrl Shift r

JT
Last edit: 27 Jul 2019 11:43 by BigJohnT.

Please Log in or Create an account to join the conversation.

More
06 Jan 2020 12:22 #154141 by DC67
hello
i changed my ini file because i want to use probe screen v2 with gmoccappy. now i always get a message at linuxcnc start (picture) i have been using v2.8 for a while without any problems and the update that he suggests doesn't work. if I click no then everything goes on normally. what am I doing wrong here?

File Attachment:

File Name: Fenja_2020-01-06.ini
File Size:6 KB
Attachments:

Please Log in or Create an account to join the conversation.

More
06 Jan 2020 18:04 #154161 by Mike_Eitel
I think Version 1.1 must be adapted. A while agoo there was something about it here on the forum
The following user(s) said Thank You: DC67

Please Log in or Create an account to join the conversation.

More
09 Jan 2020 00:34 #154369 by andypugh
Is this fixed?

Please Log in or Create an account to join the conversation.

Time to create page: 0.171 seconds
Powered by Kunena Forum