Basic GENERAL question about configuration. Plasma...

More
31 Dec 2019 17:56 - 31 Dec 2019 18:14 #153627 by CNCFred
Some question to get a picture which I don't have at the moment.

As far as I understand configure first standard machine then add plasmac, Right?

Pncconf for ethernet.. 7i76e to be configured. What is the result a spindle machine after basic configuration?

Do I need hostmot2 file? If yes where do I get it from.. Couldn't find it on Mesa web page.
Didn't find my card here http://www.linuxcnc.org/docs/html/drivers/hostmot2.html

I ordered the Thcad300 until it arrives I would like to use the plasma straight without. Is this possible in plasmac? .. I find only Modus with?

Where do the details on piercing and slowing down be implemented in an setup?

I used Db25 connectors for home switches I read plasmac has specific setup where do I find this layout is the Anschlussplan according to plasmac as well?
If yes, ignore this question... Where do I need to hook up my relais for torch...

I read user guides, maybe I am just stupid.. Forgive me but still share some answers with me...
Thank you in advance.




For my reference and others:
setup of 7i76e basic. forum.linuxcnc.org/38-general-linuxcnc-q...69-7i76e-quick-setup
Yyxz gantry forum.linuxcnc.org/47-hal-examples/34072...ranch-gantry-example
I
Last edit: 31 Dec 2019 18:14 by CNCFred.

Please Log in or Create an account to join the conversation.

More
31 Dec 2019 18:15 #153629 by CNCFred

CNCFred wrote: Some question to get a picture which I don't have at the moment.

As far as I understand configure first standard machine then add plasmac, Right?

Pncconf for ethernet.. 7i76e to be configured. What is the result a spindle machine after basic configuration?

Do I need hostmot2 file? If yes where do I get it from.. Couldn't find it on Mesa web page.
Didn't find my card here http://www.linuxcnc.org/docs/html/drivers/hostmot2.html

I ordered the Thcad300 until it arrives I would like to use the plasma straight without. Is this possible in plasmac? .. I find only Modus with?

Where do the details on piercing and slowing down be implemented in an setup?

I used Db25 connectors for home switches I read plasmac has specific setup where do I find this layout is the Anschlussplan according to plasmac as well?
If yes, ignore this question... Where do I need to hook up my relais for torch...

I read user guides, maybe I am just stupid.. Forgive me but still share some answers with me...
Thank you in advance.




For my reference and others:
setup of 7i76e basic. forum.linuxcnc.org/38-general-linuxcnc-q...69-7i76e-quick-setup
Yyxz gantry forum.linuxcnc.org/47-hal-examples/34072...ranch-gantry-example
I


Funny if you are looking for these things they don't show up.

Please Log in or Create an account to join the conversation.

More
31 Dec 2019 20:28 - 31 Dec 2019 20:36 #153633 by AgentWD40

CNCFred wrote: Some question to get a picture which I don't have at the moment.

As far as I understand configure first standard machine then add plasmac, Right?

Yeah, use pncconf to get a basic install and get jogging around your table.

Pncconf for ethernet.. 7i76e to be configured. What is the result a spindle machine after basic configuration?

I don't understand this question.
[EDIT] Remember to run the mesa ethernet cards you'll need the preempt kernel, and should upgrade to linuxcnc 2.8 or 2.9. These versions of linuxcnc will have the configuration options setup for the 7i76e, I'm not sure if pncconf installed with version 2.7 had selections for 7i76e or not, if I remember correctly I think there was hand editing of the hal file involved. But you'll need at least 2.8 for plasmac so might as well upgrade.


Do I need hostmot2 file? If yes where do I get it from.. Couldn't find it on Mesa web page.

should already be installed I think. pncconf will set it up for you in your hal file.

Didn't find my card here http://www.linuxcnc.org/docs/html/drivers/hostmot2.html

I ordered the Thcad300 until it arrives I would like to use the plasma straight without. Is this possible in plasmac? .. I find only Modus with?

Where do the details on piercing and slowing down be implemented in an setup?

I used Db25 connectors for home switches I read plasmac has specific setup where do I find this layout is the Anschlussplan according to plasmac as well?
If yes, ignore this question... Where do I need to hook up my relais for torch...

I'll leave plasmac specific questions to Phill, Rod, et al.
Of course you could still run your machine without plasmac at all until your thcad arrives.


I read user guides, maybe I am just stupid..

Not stupid. If you're new to this stuff it's really a metric crap ton of information to absorb. Everyone's setup is different, everyone has different requirements. While the new user guides are awesome, by nature they can't be entirely comprehensive so you have plenty figuring out to do on your own. Keep reading, keep asking questions, build test configs and dig through the hal/ini files, it'll all start to fall together.


Forgive me but still share some answers with me...

Only if you ask nicely.

Thank you in advance.

Yeah, like that ;)





For my reference and others:
setup of 7i76e basic. forum.linuxcnc.org/38-general-linuxcnc-q...69-7i76e-quick-setup
Yyxz gantry forum.linuxcnc.org/47-hal-examples/34072...ranch-gantry-example
I

Last edit: 31 Dec 2019 20:36 by AgentWD40.
The following user(s) said Thank You: CNCFred

Please Log in or Create an account to join the conversation.

More
01 Jan 2020 00:50 #153675 by rodw
The main ting you need to get going before plasmac is a basic machine that has the correct axis dimensions, velocity and acceleration, plus your home and limit switches, ohmic sensing and float switch.

I have not tried it but you could set plasmac up for your THCAD before hand and cut with the THC disabled and no torch voltage sampling until it arrives.
The following user(s) said Thank You: CNCFred

Please Log in or Create an account to join the conversation.

More
01 Jan 2020 07:21 - 01 Jan 2020 08:24 #153703 by CNCFred
Happy New Year!

Thank you Rodw, that I will do now.

First time yesterday a motor was turning! I am going to get a system.
My IP of 7i76e is 192.168.1.121 and it took hours to figure out.
I think the power suplies are not that clean on startup so a manual restart of the card at the end did the trick.
Of course troubleshooting with 10.10.10.10 :evil: first for hours....

Thanks!
Just deleted my nema problem... Seems power supply startup confuses a lot of things..
Last edit: 01 Jan 2020 08:24 by CNCFred.

Please Log in or Create an account to join the conversation.

Time to create page: 0.281 seconds
Powered by Kunena Forum