LinuxCNC Backslash problem

More
19 Jan 2020 09:40 #155136 by Hugues
Hi !

i'm trying to adjust the Bacslash in my file.ini

i dont understand how to do it, i dont have the bacslash line in the .ini

and if i do the configuration proposed in this tutorial :


As in this video, i m short .0035 at .5 but my x scale = 133.3333

How do i adjust this? if i do this 147.3333, nothing changes.

Thanks in advance.

Please Log in or Create an account to join the conversation.

More
19 Jan 2020 10:05 #155137 by aleksamc
Replied by aleksamc on topic LinuxCNC Backslash problem
Please add .ini file of your machine
The following user(s) said Thank You: Hugues

Please Log in or Create an account to join the conversation.

More
19 Jan 2020 10:32 - 19 Jan 2020 10:33 #155139 by Hugues
Replied by Hugues on topic LinuxCNC Backslash problem
[EMC]
MACHINE = ExMachina
DEBUG = 0

[DISPLAY]
DISPLAY = axis
EDITOR = gedit
POSITION_OFFSET = RELATIVE
POSITION_FEEDBACK = ACTUAL
ARCDIVISION = 64
GRIDS = 10mm 20mm 50mm 100mm 1in 2in 5in 10in
MAX_FEED_OVERRIDE = 1.2
MIN_SPINDLE_OVERRIDE = 0.5
MAX_SPINDLE_OVERRIDE = 1.2
DEFAULT_LINEAR_VELOCITY = 2.50
MIN_LINEAR_VELOCITY = 0
MAX_LINEAR_VELOCITY = 25.00
INTRO_GRAPHIC = linuxcnc.gif
INTRO_TIME = 5
PROGRAM_PREFIX = /home/Exmachina/linuxcnc/nc_files
INCREMENTS = 5mm 1mm .5mm .1mm .05mm .01mm .005mm

[FILTER]
PROGRAM_EXTENSION = .png,.gif,.jpg Greyscale Depth Image
PROGRAM_EXTENSION = .py Python Script
png = image-to-gcode
gif = image-to-gcode
jpg = image-to-gcode
py = python

[TASK]
TASK = milltask
CYCLE_TIME = 0.010

[RS274NGC]
PARAMETER_FILE = linuxcnc.var

[EMCMOT]
EMCMOT = motmod
COMM_TIMEOUT = 1.0
COMM_WAIT = 0.010
BASE_PERIOD = 100000
SERVO_PERIOD = 1000000

[HAL]
HALFILE = ExMachina.hal
HALFILE = custom.hal
POSTGUI_HALFILE = custom_postgui.hal

[TRAJ]
AXES = 3
COORDINATES = X Y Z
LINEAR_UNITS = mm
ANGULAR_UNITS = degree
CYCLE_TIME = 0.010
DEFAULT_VELOCITY = 2.50
MAX_VELOCITY = 25.00

EMCIO = io
CYCLE_TIME = 0.100
TOOL_TABLE = tool.tbl

[AXIS_0]
TYPE = LINEAR
HOME = 0.0
MAX_VELOCITY = 25.0
MAX_ACCELERATION = 750.0
STEPGEN_MAXACCEL = 937.5
SCALE = 133.333333333
FERROR = 1
MIN_FERROR = .25
MIN_LIMIT = -0.001
MAX_LIMIT = 400.0
HOME_OFFSET = 0.000000
HOME_SEARCH_VEL = 1.500000
HOME_LATCH_VEL = 1.500000
HOME_IGNORE_LIMITS = YES
HOME_SEQUENCE = 1

[AXIS_1]
TYPE = LINEAR
HOME = 0.0
MAX_VELOCITY = 25.0
MAX_ACCELERATION = 750.0
STEPGEN_MAXACCEL = 937.5
SCALE = 133.333333333
FERROR = 1
MIN_FERROR = .25
MIN_LIMIT = -0.001
MAX_LIMIT = 400.0
HOME_OFFSET = 0.000000
HOME_SEARCH_VEL = 1.500000
HOME_LATCH_VEL = 1.500000
HOME_IGNORE_LIMITS = YES
HOME_SEQUENCE = 2

[AXIS_2]
TYPE = LINEAR
HOME = 0.0
MAX_VELOCITY = 25.0
MAX_ACCELERATION = 750.0
STEPGEN_MAXACCEL = 937.5
SCALE = 133.333333333
FERROR = 1
MIN_FERROR = .25
MIN_LIMIT = -0.001
MAX_LIMIT = 100.0
HOME_OFFSET = 0.000000
HOME_SEARCH_VEL = 1.500000
HOME_LATCH_VEL = 1.500000
HOME_IGNORE_LIMITS = YES
HOME_SEQUENCE = 0
Last edit: 19 Jan 2020 10:33 by Hugues.

Please Log in or Create an account to join the conversation.

More
19 Jan 2020 11:40 #155141 by Leon82
Replied by Leon82 on topic LinuxCNC Backslash problem
Add
BACKLASH = .0035


TO THE AXIS section.
The following user(s) said Thank You: Hugues

Please Log in or Create an account to join the conversation.

More
19 Jan 2020 11:46 #155142 by Leon82
Replied by Leon82 on topic LinuxCNC Backslash problem

Leon82 wrote: Add
BACKLASH = .0035


TO THE AXIS section.


When checking scale go in the same direction so backlash isn't a factor
The following user(s) said Thank You: Hugues

Please Log in or Create an account to join the conversation.

More
19 Jan 2020 16:08 #155159 by JohnnyCNC
Before addressing backlash you must have the actual movement matching the commanded movement. What I would do it to run pncconf or stepconf and create a new machine making sure all of the values entered for each axis are correct. This is just so you can get the scale number that was created with known correct entries in the config program. Then you can delete the new machine. Use the new scale number in your ini file and test the actual movement. If it is off then tweak the scale number and retest. Repeat as needed until it is right. Once that is set you can move on to the backlash setting.
To test the back lash. Move the axis in the positive direction. Zero the indicator and then move in the negative direction and note the difference in the actual distance compared to the commanded distance. Put that number in the backlash ini setting and test again. I tested mine in both the positive followed by negative and negative followed by positive. Keep tweaking the ini setting by bumping the number up and down and retesting until you can’t make any improvement in the error.

Please Log in or Create an account to join the conversation.

More
19 Jan 2020 22:28 #155203 by phillc54
Replied by phillc54 on topic LinuxCNC Backslash problem
If you do add BACKLASH to an [AXIS_N] section then you need to set STEPGEN_MAXACCEL to 1.5 to 2 times MAX_ACCELERATION for that axis.
You do need to have your SCALE set correctly before adding BACKLASH.

Please Log in or Create an account to join the conversation.

Time to create page: 0.093 seconds
Powered by Kunena Forum