2013 Arduino HackCNC doesn't work in 2020

More
10 Jun 2020 11:09 #170946 by ivanfet
Hi everyone.

Back in 2013, I built a HackCNC at linux.conf.au and the device worked well with LinuxCNC and the supplied software files.

Details on the HackCNC can be found here -

www.openhardwareconf.org/index.php/HackCNC_Assembly_Tips
github.com/CCHS-Melbourne/HackCNC

Today in 2020, I have tried to run the device again with LinuxCNC following the 2013 instructions, using the current version of LinuxCNC and the 2013 ini and hal files. I get the following errors below.

Does anyone have any suggestions how to get my HackCNC to work with LinuxCNC or what is going wrong? I don't have a Stepconf file to use the Wizard.

Cheers Ivan

Error report created by /usr/lib/tcltk/linuxcnc/show_errors.tcl:

Print file information:
RUN_IN_PLACE=no
LINUXCNC_DIR=
LINUXCNC_BIN_DIR=/usr/bin
LINUXCNC_TCL_DIR=/usr/lib/tcltk/linuxcnc
LINUXCNC_SCRIPT_DIR=
LINUXCNC_RTLIB_DIR=/usr/lib/linuxcnc/modules
LINUXCNC_CONFIG_DIR=
LINUXCNC_LANG_DIR=/usr/lib/tcltk/linuxcnc/msgs
INIVAR=inivar
HALCMD=halcmd
LINUXCNC_EMCSH=/usr/bin/wish8.6
LINUXCNC - 2.8.0-pre1-5947-g282aaee55
Machine configuration directory is '/home/ivan/linuxcnc/configs/my-mill'
Machine configuration file is 'my-mill.ini'
INIFILE=/home/ivan/linuxcnc/configs/my-mill/my-mill.ini
VERSION=1.1
check_config validation failed

Debug file information:
can't read "::kins(module)": no such variable
while executing
"puts "\n$::progname: ($::kins(module) kinematics) ERROR:""
(procedure "err_exit" line 2)
invoked from within
"err_exit $emsg"
invoked from within
"if [info exists emsg] {
err_exit $emsg
}"
(procedure "check_mandatory_items" line 8)
invoked from within
"check_mandatory_items"
(file "/usr/share/linuxcnc/hallib/check_config.tcl" line 153)



Info report created by linuxcnc_info:
The file: /tmp/linuxcnc_info.txt
can be posted to a forum or a web site like:
pastebin.com
in order to provide information about the linuxcnc
system and configuration.

Date: Wed 10 Jun 15:48:20 AWST 2020
UTC Date: Wed 10 Jun 07:48:20 UTC 2020
this program: /usr/bin/linuxcnc_info
uptime: 15:48:20 up 50 min, 1 user, load average: 0.22, 0.26, 0.26
lsb_release -sa: LinuxMint Linux Mint 19.3 Tricia 19.3 tricia
which linuxcnc: /usr/bin/linuxcnc
pwd: /home/ivan
USER: ivan
LOGNAME: ivan
HOME: /home/ivan
EDITOR:
VISUAL:
LANGUAGE: en_AU:en
TERM: dumb
COLORTERM:
DISPLAY: :0
DESKTOP: cinnamon
display size: 2560x1440 pixels (677x381 millimeters)
PATH: /usr/bin:/home/ivan/linuxcnc/configs/my-mill/bin:/usr/bin:/home/ivan/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games

uname items:
nodename -n: ivan-Workstation
kernel-name -s: Linux
kernel-vers -v: #202005312130 SMP Mon Jun 1 01:33:12 UTC 2020
machine -m: x86_64
processor -p: x86_64
platform -i: x86_64
oper system -o: GNU/Linux

/proc items:
cmdline: BOOT_IMAGE=/boot/vmlinuz-5.7.0-050700-generic root=UUID=fa8d9287-aa23-4c7c-96b1-501723d4fc90 ro quiet splash vt.handoff=1
model name: AMD Ryzen 9 3900X 12-Core Processor
cores: 12
cpu MHz: 2183.307
parport:
serial: 0000-0000 : serial

Versions:
gcc: gcc (Ubuntu 7.5.0-3ubuntu1~18.04) 7.5.0
python: Python 2.7.17
git: git version 2.17.1
git commit: NA
tcl: 8.6
tk: 8.6
glade: not_in_PATH
glade-gtk2: not_in_PATH

linuxcnc_var all:

LINUXCNCVERSION: 2.8.0-pre1-5947-g282aaee55
LINUXCNC_AUX_GLADEVCP: /usr/share/linuxcnc/aux_gladevcp
LINUXCNC_AUX_EXAMPLES: /usr/share/linuxcnc/aux_examples
REALTIME: /etc/init.d/realtime
RTS: uspace
HALLIB_DIR: /usr/share/linuxcnc/hallib

dpkg -l '*linuxcnc*':
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-===============-============================-============-=============================================
un linuxcnc <none> <none> (no description available)
un linuxcnc-doc <none> <none> (no description available)
un linuxcnc-doc-en <none> <none> (no description available)
un linuxcnc-sim <none> <none> (no description available)
ii linuxcnc-uspace 1:2.8.0~pre1.5947.g282aaee55 amd64 motion controller for CNC machines and robots

Please Log in or Create an account to join the conversation.

More
10 Jun 2020 11:26 #170950 by Grotius
Hi,

Your hal and ini files have to be made compatible with [joint] instead of [axis]. Thats one reason it will not work with current
linuxcnc editions.

Please Log in or Create an account to join the conversation.

More
10 Jun 2020 12:10 #170954 by bbsr_5a
it will run with the latest ISO 2.7.11
the 2.8+ are using other internals

Please Log in or Create an account to join the conversation.

More
10 Jun 2020 15:11 #170968 by ivanfet
Thanks, that worked. I removed version 2.8 and installed 2.7. Now LinuxCNC runs the old files.

Please Log in or Create an account to join the conversation.

More
10 Jun 2020 17:16 #170978 by bbsr_5a
If you need the advantige from 2.9 like QTvcp
you need to setup a new machine via the wizards and take the values from the ini

Please Log in or Create an account to join the conversation.

More
10 Jun 2020 17:44 #170980 by Todd Zuercher
There are provisions for automatically converting older older configuration files in 2.8 and Master that are run the first time you try to open them for the first time, unless you choose not to. The conversion script prompts you before proceeding with the conversion (you should allow it to.) The conversion script works well for most standard machine configs. But very unique or complex configs may easily trip up the scripts that perform the auto translation. If you were capable of generating such a config, you should also posses the skills to easily diagnose and correct the errors made by the auto conversion, once you've familiarized yourself with the changes in 2.8.

Please Log in or Create an account to join the conversation.

More
10 Jun 2020 19:36 #170990 by tommylight
Master has a bit of an issue with the updater and the tkinter not being found although it is installed, due to moving to Python3.
2.8 works always, it did work on some heavily modified config files a while back.

Please Log in or Create an account to join the conversation.

Time to create page: 0.132 seconds
Powered by Kunena Forum