A axis rotab setup

More
05 Jul 2020 19:53 - 05 Jul 2020 20:02 #173687 by JR1050
A axis rotab setup was created by JR1050
What should be a relatively simple task has hit a snag. I have an older M&M precision A axis table, dc motor with a tach and a 2048 cpr encoder. I cant say i have ever set up a rotary axis before, and Im pretty sure I have missed something simple. using a known working config, I added a section to the ini and hal files. Set up is a RSPI 3 with a 7i90/7i33 in spi , a known working combo(and handy for bench testing). The table is driven with an AMCI 16a20 amp, setup works using a 5v battery as source. When hooked up to the 7i33 and commanded to jog , it runs away the following error distance, then trips the following error, when reset it takes off the other way. Encoder seems to count. I believe the ratio is 90:1 , so my math says( (2048x4) x90)/360)=2048- which is my input scale. I am missing something, and I couldn't find any examples of a rotab set up. Ini and hal attached, all and any help appreciated.

Ill add, the encoder is mounted on the worm, not the end of the motor, maybe the scale need to be inverted?

File Attachment:

File Name: rotab.ini
File Size:5 KB

File Attachment:

File Name: rotab_2.hal
File Size:14 KB
Attachments:
Last edit: 05 Jul 2020 20:02 by JR1050.

Please Log in or Create an account to join the conversation.

More
07 Jul 2020 14:58 #173847 by tommylight
Replied by tommylight on topic A axis rotab setup
What is rotab?

Please Log in or Create an account to join the conversation.

More
07 Jul 2020 16:52 #173867 by JR1050
Replied by JR1050 on topic A axis rotab setup
Rotary table, 4th axis , A axis. I figured it out . Switching the tach wires and motor wires and adding a little ff1 got it working. Tach needs to be scaled in the amp more accurately.

Please Log in or Create an account to join the conversation.

Time to create page: 0.122 seconds
Powered by Kunena Forum