another pci parallel card configuraion issue

More
11 Jul 2020 22:11 #174334 by jruffsr
I am working on moving my MicroPro Systems MicroMill 2000 to LinucCNC. The original computer has died and I have replaced it whih a newer computer. The old system was running Mach3 but the drivers were so old I had to maintain the PC date in the 1990's. So when it died I decided to follow the LInuxCNC path .The new system does not have a LPT port so I installed a startTech PEX1P which has one of the chip sets recommended on the forum. The following are the steps I have examined to look for a solution.

Hardeware: ASROCK Z77 Extreme4
System; Linux Mint
jruffsr@jruffsr-shop:~/linuxcnc/configs/Mach3Mill$ uname -a
Linux jruffsr-shop 4.19.106-rt44-lcnc #1 SMP PREEMPT RT Thu Mar 5 00:02:34 AEDT 2020 x86_64 x86_64 x86_64 GNU/Linux
No LPT settings in the BIOS to check.

Running lspci -vv of found the following.
02:00.0 Parallel controller: Oxford Semiconductor Ltd Device c110 (prog-if 02 [ECP])
Subsystem: Oxford Semiconductor Ltd Device c110
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 32 bytes
Interrupt: pin A routed to IRQ 16
Region 0: I/O ports at d010
Region 1: I/O ports at d000
Capabilities: <access denied>
Kernel driver in use: parport_pc
Kernel modules: parport_pc

So I ran StepConf Wizard and imported my old Mach2Mill.xml settings file.
I changed the parport to 0xd010 from the information found above. But i was unable to get any response from the mill.

Mach3Mill.hal entries
loadrt hal_parport cfg="0xd000 out"
setp parport.0.reset-time 5000
loadrt stepgen step_type=0,0,0,0

addf parport.0.read base-thread
addf stepgen.make-pulses base-thread
addf parport.0.write base-thread
addf parport.0.reset base-thread

running lsmod I found the following
parport_pc 32768 1
ppdev 20480 0
lp 20480 0
parport 49152 3 parport_pc,lp,ppdev


I am very new to Linux and and getting nowhere on a solution.
Any help would be appreciated
Thanks
Jeff Ruff

Please Log in or Create an account to join the conversation.

More
12 Jul 2020 08:32 #174363 by tommylight
loadrt hal_parport cfg="0xd010 out"
Try that

Please Log in or Create an account to join the conversation.

More
15 Jul 2020 12:24 #174743 by Todd Zuercher
The kernel is detecting and configuring the parallel port so just using the port number instead of the full address should work.
loadrt hal_parport cfg="0 out"

Please Log in or Create an account to join the conversation.

More
15 Jul 2020 12:28 #174744 by Todd Zuercher
What does typing this command at the command prompt show?
cat /proc/ioports |grep parport

Please Log in or Create an account to join the conversation.

Time to create page: 0.089 seconds
Powered by Kunena Forum