Why would my z motor only spin one way?

More
27 Nov 2021 12:12 - 27 Nov 2021 12:17 #227733 by Rational
Hi there,
First post. I've been building a printnc machine and loving it.

But spent the last three days learning linuxcnc setup. I've been able to get the basic config working on a testbed.

All motors are spinning and I can home and jog the machine successfully. It's set up as an XYYZ machine with a motor for each y rail.

After homing I can jog with the arrow keys for x right and left just fine.

I can also jog forward and back for the y axis with the up and down arrows just fine.

But the z motor only spins one direction (cw) when I switch between my page up and page down buttons.

Why would a motor only spin one direction?

I've validated it's not the motor by swapping it with the x motor.

I've validated it's not the stepper by swapping it with the x stepper.

So I'm thinking it is either my cable from my bob or something in software. I lean towards software.

Any ideas what setting may be causing this?

Here are my z axis settings from the .ini file:
[AXIS_Z]
MAX_VELOCITY = 25.0
MAX_ACCELERATION = 750.0
MIN_LIMIT = -100.0
MAX_LIMIT = 0.001

[JOINT_3]
TYPE = LINEAR
HOME = 0.0
MIN_LIMIT = -100.0
MAX_LIMIT = 0.001
MAX_VELOCITY = 25.0
MAX_ACCELERATION = 750.0
STEPGEN_MAXACCEL = 937.5
SCALE = 80.0
FERROR = 1
MIN_FERROR = .25
HOME_OFFSET = 0.000000
HOME_SEARCH_VEL = 1.500000
HOME_LATCH_VEL = 1.500000
HOME_SEQUENCE = 0

Here are my .hal relevant entries. At least I think these are the relevant ones you'll need to see:

net zstep           => parport.0.pin-08-out
setp parport.0.pin-08-out-reset 1
net zdir            => parport.0.pin-09-out

setp stepgen.3.position-scale [JOINT_3]SCALE
setp stepgen.3.steplen 1
setp stepgen.3.stepspace 0
setp stepgen.3.dirhold 14000
setp stepgen.3.dirsetup 14000
setp stepgen.3.maxaccel [JOINT_3]STEPGEN_MAXACCEL
net zpos-cmd joint.3.motor-pos-cmd => stepgen.3.position-cmd
net zpos-fb stepgen.3.position-fb => joint.3.motor-pos-fb
net zstep <= stepgen.3.step
net zdir <= stepgen.3.dir
net zenable joint.3.amp-enable-out => stepgen.3.enable
net home-z => joint.3.home-sw-in

Thank you for any hints on what it may be.

PS, I am not yet familiar with what settings I need to set for maxaccell, so perhaps these are out of bounds? Or other variables as I'm still needing to determine what to use as optimal.

I've also attached my .hal and .ini files for reference if it helps as I'm unsure if I have them completely correct as yet. Any review of them is greatly appreciated.


 
Attachments:
Last edit: 27 Nov 2021 12:17 by Rational.

Please Log in or Create an account to join the conversation.

More
27 Nov 2021 12:18 #227736 by chris@cnc
First idea
change your DIR signal 
net z2dir            => parport.0.pin-09-out
to
net zdir            => parport.0.pin-09-out
I guess there is a mix config from a tandem z-axis

Please Log in or Create an account to join the conversation.

More
27 Nov 2021 12:28 - 27 Nov 2021 12:33 #227739 by Rational
Ah yes. I already caught that one earlier and edited and re-saved my file I thought already. Hmmm. I need to double check it saved and which one I uploaded. It's been a long three days. I'm a bit cross eyed at this point. Thank you for reconfirming I caught at least one thing so far Chris.

Well, that was it. I'd already caught the typo but failed to edit the right copy or save it. I distinctly remember saving it so must have been editing another copy in another folder and not noticing from exhaustion.

Thank you Chris. This issue is fixed.

I do have another question but am unsure if I should start a new thread or just ask it real quick here so will just ask for now.

Homing of my y axis speed is very very slow in comparison to the others. Where is that set and how do I make the motor speed match the others?

Thank you again.

Actually I think I found it: HOME_SEARCH_VEL = 30. Is that a good level?
And are my other levels pretty typical and within ranges? Or is there a reference I can look to to help me set initial levels a bit better?
Last edit: 27 Nov 2021 12:33 by Rational.

Please Log in or Create an account to join the conversation.

More
27 Nov 2021 12:37 - 27 Nov 2021 12:39 #227740 by chris@cnc
Glad that i could help. Yes, after three nights are the eyes tired. 

Your homing speed is adjust in *.ini. line
HOME_SEARCH_VEL = 1.500000
HOME_LATCH_VEL = 1.500000

linuxcnc.org/docs/2.8/html/config/ini-ho...tml#_home_search_vel
The speed depend on your hardware. If you get a stable point its okay
Last edit: 27 Nov 2021 12:39 by chris@cnc.

Please Log in or Create an account to join the conversation.

Time to create page: 0.056 seconds
Powered by Kunena Forum