Weird homing behavior. Y+Y2 out of sync

More
05 May 2022 17:52 #242056 by AJ
Hello!
Long time lurker, first time poster here.
Finishing up my first DIY CNC plasma table. (Many of you guys have been a huge help to me without even knowing! :) Big thanks for that!)
Got stuck with a weird homing issue - YY2 axis goes searching for the home sensors (both motors at the same time with the same velocity), latches to the sensors (also in sync), and then they both drive to the final home separately, Y and then Y2...
I've tried changing the homing sequence to 1 2 2 3, 1 -2 -2 3, 1 2 -2 3, 1 -2 2 3. Tried creating new configuration using pncconfig - always the same result.
After the homing everything works fine. Tried some dry runs, tried cutting some straight lines - no problem. Just the homing. Unless its supposed to be like that?

File Attachment:

File Name: PlasmaCNC.ini
File Size:6 KB

File Attachment:

File Name: PlasmaCNC.hal
File Size:11 KB
Attachments:

Please Log in or Create an account to join the conversation.

More
05 May 2022 21:11 #242070 by rodw
Try changing the home_sequence to -1 in you ini file. I don't think -2 is legal unless there is another joint axis.
The following user(s) said Thank You: AJ

Please Log in or Create an account to join the conversation.

More
05 May 2022 21:12 #242071 by tommylight
Does it have the same value for HOME_FINAL_VELOCITY ?
A video from each side of the gantry during homing would help, so that is 2 videos... :)
The following user(s) said Thank You: AJ

Please Log in or Create an account to join the conversation.

More
05 May 2022 21:46 #242075 by Clive S
In the ini file you have:-

HOME = 2950.0

HOME_OFFSET = 2960.000000 ( I generally use this to square the gantry with a low number like 1-5 mm)
HOME_SEARCH_VEL = 83.333333 ( this is the speed to the home switch)
HOME_LATCH_VEL = 16.666667 (this is the speed to the latch position. I generally back off so might need to put a - in front. ie -16.666)

HOME_FINAL_VEL = 0.000000 (this is the speed to the home position)

HOME_SEQUENCE = -2 ( this is fine for both Y joints)

From the manual linuxcnc.org/docs/devel/html/config/ini-...tml#_homing_sequence
The following user(s) said Thank You: AJ

Please Log in or Create an account to join the conversation.

More
05 May 2022 22:09 #242076 by rodw

HOME_SEQUENCE = -2 ( this is fine for both Y joints)
 

That does not agree with the docs which state:
The initial HOME_SEQUENCE number may be 0, 1 (or -1). The absolute value of sequence numbers must increment by one — skipping sequence numbers is not supported. If a sequence number is omitted, HOME ALL homing will stop upon completion of the last valid sequence number.
Ref: linuxcnc.org/docs/devel/html/config/ini-...tml#_homing_sequence

Please Log in or Create an account to join the conversation.

More
05 May 2022 22:38 #242078 by tommylight

HOME_SEQUENCE = -2 ( this is fine for both Y joints)

 
That does not agree with the docs which state:
The initial HOME_SEQUENCE number may be 0, 1 (or -1). The absolute value of sequence numbers must increment by one — skipping sequence numbers is not supported. If a sequence number is omitted, HOME ALL homing will stop upon completion of the last valid sequence number.
Ref: linuxcnc.org/docs/devel/html/config/ini-...tml#_homing_sequence

Not sure how you're reading this, but i am reading it as sequence numbers can be 0, 1 or -1, 2 or -2, 3 or -3, 4 or -4, 5 or -5 etc
So if he already has 0 for Z axis, 1 for X axis, yes, he should have -2 for Y tandem axis. Can not have 1 for X and -1 for Y, that will not work ... although i never checked, so .... :)
The following user(s) said Thank You: Clive S

Please Log in or Create an account to join the conversation.

More
06 May 2022 05:59 #242103 by Clive S

HOME_SEQUENCE = -2 ( this is fine for both Y joints)
 
That does not agree with the docs which state:
The initial HOME_SEQUENCE number may be 0, 1 (or -1). The absolute value of sequence numbers must increment by one — skipping sequence numbers is not supported. If a sequence number is omitted, HOME ALL homing will stop upon completion of the last valid sequence number.
Ref: linuxcnc.org/docs/devel/html/config/ini-...tml#_homing_sequence


I don't see where he is skipping numbers

He has in the ini file :-
HOME_SEQUENCE Z = 0 . X = 1 . Y1 and Y2 = -2

Please Log in or Create an account to join the conversation.

More
06 May 2022 09:22 #242107 by AJ
They do have the same HOME_FINAL_VELOCITY. In my understanding 0 = max velocity setting? And both joints were set to 25000mm/min if I remember correctly.
Here's a video Tommy

Please Log in or Create an account to join the conversation.

More
06 May 2022 09:29 #242108 by AJ
Rod, I've tried many different combinations for the homing sequence - always the same result...

Please Log in or Create an account to join the conversation.

More
06 May 2022 10:17 #242115 by tommylight
That looks perfectly normal.
The only possible issue might be miss wired switches, although i doubt it, so rake the gantry a bit on one side by hand and then home while watching from the side.
Otherwise, all is good, you have the final velocity set to maximum or 0 so after latching it flies to the final position, so a small difference during latching is magnified by the speed and the short distance it takes to get to final position.
Mine do that daily and i have some offset (5mm difference between them), but i have HOME_FINAL_VELOCITY at 30 so it goes slower and i enjoy watching them do their dance ! :)

Please Log in or Create an account to join the conversation.

Time to create page: 0.145 seconds
Powered by Kunena Forum