hm2: Firmware contains unknown function (gtag-45)

More
24 Jun 2022 02:07 #245751 by tommylight
In a terminal:
uname -a

Please Log in or Create an account to join the conversation.

More
24 Jun 2022 03:08 #245755 by TriCnC2022
Ok. I will check tomorrow night and post again. I’d travel for work and already pack my system up. Thanks Tommy 
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
26 Jun 2022 03:01 #245898 by TriCnC2022
I got it to work. All I had to do was edit the ini file and add an s at the end of 7i96 and that did it. Thanks everyone for the input. I’m sure I’ll have many more questions while testing this out. Thanks again.

Please Log in or Create an account to join the conversation.

More
26 Jun 2022 10:47 #245906 by tommylight
Nice :)
You are welcomed, always.
And thank you for reporting back.

Please Log in or Create an account to join the conversation.

More
28 Jun 2022 22:12 #246115 by andypugh

I got it to work. All I had to do was edit the ini file and add an s at the end of 7i96 and that did it. 

I am still a bit concerned about "Posix non-realtime" 

Please Log in or Create an account to join the conversation.

More
03 Aug 2022 13:27 - 03 Aug 2022 13:28 #248931 by xenon-alien
Hello!

1) How can I solve the problem?
The LCNC was 2.7.14 (from the downloads Debian Strech)
Updated the LCNC without deleting 2.7.14  from Synaptic and get 2.9 master
Deleted the mesaflesh 3.3 from Synaptic, then updated in terminal to 3.4.3.
Have the same issue, but not helping renaming the card to 7i96s. Receiving an error - does not exist.
If leave it as it is was with just 7i96 it loads the LCNC with an error - hm2: Firmware contains unknown function (gtag-45).
 
   

2) How to control the 4-5 AC Outputs and analog for spindle?

3) Is it possible to make a firmware which can use the servos index for homing?
It will be a lathe, so the 5th (04,03) stepgen not needed and use 2 pins, like 5v Index input from servo motor for X and Z axis.
Attachments:
Last edit: 03 Aug 2022 13:28 by xenon-alien.

Please Log in or Create an account to join the conversation.

More
03 Aug 2022 14:25 #248934 by PCW
Both errors are because you are running LinuxCNC 2.8. The 7I96S requires LinuxCNC 2.9

Please Log in or Create an account to join the conversation.

More
04 Aug 2022 06:16 - 04 Aug 2022 06:23 #249006 by xenon-alien

Both errors are because you are running LinuxCNC 2.8. The 7I96S requires LinuxCNC 2.9 

How can it be? 2.8Do you see the synaptic LCNC version?The first try was 2.8, but then I updated to 2.9 and the 2.9 gives me the same error. Or I did something wrong with updating to 2.9 master 
Here is the report file
 

File Attachment:

File Name: linuxcnc.ini
File Size:9 KB

Attachments:
Last edit: 04 Aug 2022 06:23 by xenon-alien.

Please Log in or Create an account to join the conversation.

More
04 Aug 2022 06:48 #249007 by phillc54
LINUXCNC - 2.9.0-pre0-3879-g9a26e69fe is dated around 11 May 2021 and is probably too old for the 7i96s.

You are using Debian Stretch which I think does not support latest master branch (2.9), you need Debian Buster or later.


 
The following user(s) said Thank You: xenon-alien

Please Log in or Create an account to join the conversation.

More
04 Aug 2022 07:01 #249008 by xenon-alien

LINUXCNC - 2.9.0-pre0-3879-g9a26e69fe is dated around 11 May 2021 and is probably too old for the 7i96s.

You are using Debian Stretch which I think does not support latest master branch (2.9), you need Debian Buster or later.



 

I will try the last ISO image

Please Log in or Create an account to join the conversation.

Time to create page: 0.232 seconds
Powered by Kunena Forum