Can not wrap my head around homing

More
22 Mar 2024 23:21 - 23 Mar 2024 23:24 #296560 by LinuxPlasma
Hello,for quite some time I am trying to get a CNC plasmacutter that was given to me to run and cut.By now I got it to move correctly and fire the torch, but one thing I seemingly can not warp my head around is homing. I do not have limit nor home switches, as I am limited to one LPT connection and am trying to use the inputs for a Proma THC.I am running PlasmaC in an Axis Window on 2.8.4 on a Thinkpad T43, if that matters.What I would like to achieve: Jog the axes manually to a zero position (left, front) by eye, then zero them out and start cutting. Whatever I try, I can not get it to work, and it seems like I have spent too much time fiddling around in settings a probably shouldn't have.I attached my .ini and .hal, and would be really happy if someone could tell me what I'd have to change to achieve what I described above, and what user inputs in LinuxCNC I would need to give the machine.Thanks.
Attachments:
Last edit: 23 Mar 2024 23:24 by LinuxPlasma. Reason: messed up the attachments

Please Log in or Create an account to join the conversation.

More
23 Mar 2024 01:42 #296566 by tommylight


What I would like to achieve: Jog the axes manually to a zero position (left, front) by eye, then zero them out and start cutting. 


That is very easy to do, just do not choose home switches in the wizard.
Probably making a new config would be easier, as editing the existing config might prove harder as from a quick glance there are entries for index and some other strange stuff.
The following user(s) said Thank You: LinuxPlasma

Please Log in or Create an account to join the conversation.

More
23 Mar 2024 23:22 - 23 Mar 2024 23:25 #296601 by LinuxPlasma
Thank you for your reply.
I just did just run the the stepconf wizard and the PlasmaC wizard to make a new config, left the input pins for the limit switches blank and did not fill in anything regarding home switches in the axis screens.
I still get the error shown in the attached picture. (Sorry about the language mixup, it says something like "programme cannot be executed without prior homing" and "MDI command cannot be executed without prior homing").

The issue I have is that I can not move the tool past the red X and Y lines, in this picture it would be to the left and downwards.
I have to press the homing button in order to be able to zero them without error messages, but then the soft limits seem to limit my travel.

So if the tool is somewhere in the right upper side but my zero would be in the left lower side, how do I do that?

I attached th inis and hals again, just for reference, but have not touched them, they are straight out of the wizards. 
Attachments:
Last edit: 23 Mar 2024 23:25 by LinuxPlasma. Reason: Readability

Please Log in or Create an account to join the conversation.

More
24 Mar 2024 03:53 #296612 by phillc54

The issue I have is that I can not move the tool past the red X and Y lines, in this picture it would be to the left and downwards.
I have to press the homing button in order to be able to zero them without error messages, but then the soft limits seem to limit my travel.

So if the tool is somewhere in the right upper side but my zero would be in the left lower side, how do I do that?

For your config with immediate homing you need to have the tool in the lower left position (home), the z height should be at the half way mark (home), and then press the homing button.

I would recommend changing the Z so that home is at or near the top.

It is possible jog before homing by setting NO_FORCE_HOMING = 1 in the [TRAJ]  section of the .ini file but you need to be very careful as you have no limit switches. 
The following user(s) said Thank You: LinuxPlasma

Please Log in or Create an account to join the conversation.

More
24 Mar 2024 23:22 #296658 by LinuxPlasma
Thank you.

If I read correctly, NO_FORCE_HOMING = 1 would mean, the soft limits are deactivated, am I right?

The most feasible way for me would probably be to move the gantry to home manually before switching on the system, so that home is at XYZ 0,0,0, and once I press the homing button it does not move.

I am just surprised that I seemingly can not move the axis under their own power and then tell the system "this is now home, go max +XXX mm on X and max +XXX mm on Y and then stop, because you hit your soft limits".


Maybe I am mixing something up here or am just too low on experience when it comes to CNC systems.

Please Log in or Create an account to join the conversation.

More
24 Mar 2024 23:55 #296659 by phillc54


If I read correctly, NO_FORCE_HOMING = 1 would mean, the soft limits are deactivated, am I right?

Yes, soft limits are activated after homing.

The most feasible way for me would probably be to move the gantry to home manually before switching on the system, so that home is at XYZ 0,0,0, and once I press the homing button it does not move.

Yes, although it could be at coordinates other than 0,0,0. On my old lathe that had immediate homing I lined up some match marks I had scratched into it at specific coordinates and they were set as the home and home_offset coordinates in the .ini file.

I am just surprised that I seemingly can not move the axis under their own power and then tell the system "this is now home, go max +XXX mm on X and max +XXX mm on Y and then stop, because you hit your soft limits".

Only because as a default LinuxCNC does not allow jogging before homing.
The following user(s) said Thank You: LinuxPlasma

Please Log in or Create an account to join the conversation.

More
25 Mar 2024 00:44 #296663 by tommylight
Leme try to explain:
-before using the machine move it to 0,0 on X and Y by hand (this can also be done in gcode so the machine moves to 0.0 at the end of work, easier to use)
-home the machine
-jog the machine to material 0.0, use the "touch off" button on screen to set the 0.0 on G54 (press touch off see if the value is 0 and press enter, choose other axis do the same)
-
To have gcode return the machine at the end of work, add G53 X0 Y0 at the end of the gcode file or set the CAM to do that.
This is much better than homing at material 0 as that will also move the soft limits so the machine can easily try to move out of physical boundaries. With this method tha can not happen as the soft limits stay inside the machine limits.
The following user(s) said Thank You: LinuxPlasma

Please Log in or Create an account to join the conversation.

More
26 Mar 2024 10:29 #296804 by LinuxPlasma

Only because as a default LinuxCNC does not allow jogging before homing.


Thank you, that was exactly the thing I could not wrap my head around because it didn't make any sense to me. It still doesn't, but now I can work around it.

Please Log in or Create an account to join the conversation.

More
26 Mar 2024 10:48 - 26 Mar 2024 10:50 #296805 by LinuxPlasma

Leme try to explain:


Thank you for the explanation, I will try it that way.

Now I first have to get my Proma THC working to get the ArcOk and then I hopefully can start dialling in the machine.

Last edit: 26 Mar 2024 10:50 by LinuxPlasma.
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

Time to create page: 0.225 seconds
Powered by Kunena Forum