linuxcnc-2.8.0-pi4.img - no USB on raspberry pi 4 - 8GB & 2GB

More
18 Jan 2021 12:37 #195778 by antage
It early used total_mem hack to limit DMA address zone (DMA safe zone must be <3GB address). But 4.19 has all fixes for these issues for 32-bit and 64-bit kernel. It may be another issue with >3GB but I can't find it in raspberrypi/linux github issues.

Please Log in or Create an account to join the conversation.

More
19 Jan 2021 01:21 - 19 Jan 2021 01:29 #195852 by andypugh
Well, I am confused now.

Intending to investigate the effect of limiting memory to 3GB I made a new standard 32-bit SD card image, booted my new 2GB Pi4 (bought specifically to debug this reported issue) and followed the instructions here in the LinuxCNC docs:
linuxcnc.org/docs/2.8/html/getting-start...lling_on_raspbian_10
Contrary to the reports in this and other threads, it all "just worked".

I moved the SD card to my Pi400, and that worked, and then to my old 4GB Pi4, and that worked.

Is there _actually_ a problem?

Also, can we move this discussion to one thread, ie this one:
forum.linuxcnc.org/9-installing-linuxcnc...-work?start=0#194602
Last edit: 19 Jan 2021 01:29 by andypugh.

Please Log in or Create an account to join the conversation.

More
19 Jan 2021 04:50 - 19 Jan 2021 04:50 #195868 by johnp

Is there _actually_ a problem?

On my 8GB Pi4, after following the instructions here
linuxcnc.org/docs/2.8/html/getting-start...lling_on_raspbian_10

I can only get USB working by setting total_mem to a maximum of 3072.
I can do this before or after installing the realtime kernel and back an forth. Anytime total_mem is greater than 3072 my USB stops working.

Also, can we move this discussion to one thread, ie this one:
forum.linuxcnc.org/9-installing-linuxcnc...-work?start=0#194602

Sounds reasonable as the 2GB bit in this thread title is misleading.
Last edit: 19 Jan 2021 04:50 by johnp.

Please Log in or Create an account to join the conversation.

More
29 Jan 2021 16:51 #197070 by bdp32
I'd just like to say I've just experienced the No USB with a 2GB pi 4

This is my second pi 4, the first just worked. However this second pi, I took it straight out of the box and put a linuxcnc image in it straight away, the first one I had used for other things first. Thinking that this was the issue I booted a standard raspbian image which worked as expected. Rebooted with LinuxCNC image, still no USB. So can confirm that 2GB is affected.

I will troubleshoot and see if I can work out what's going on.

Please Log in or Create an account to join the conversation.

More
29 Jan 2021 17:03 #197071 by andypugh
_Which_ LinuxCNC image?

Have you tried linuxcnc-2.8.1-pi4.img ?

Please Log in or Create an account to join the conversation.

More
30 Jan 2021 18:15 #197169 by jfselcnc
Dear andypugh,

I have experienced the same issue with no USB oder Wifi with a 4G raspi 4. I have used the 2.8.0 img that was linked directly on the entry page (sorry, didn't even get as far as your getting started page). Here I had to add the 3GByte limit and it worked just fine.

Is there any advantage of now using the new 2.8.1 img? I'd rather not setup everything again, if there is not a major advantage. I am up and running with 2.8.0 and all online updates (with 3G limit of course).

Thanks for the linuxcnc image!

PS: I am all new to CNC and will build my CNC-Dötzchen in May 2021 - until then I am practicing CAD ;-) - so no experience and CNC setup yet, just prep work.

Please Log in or Create an account to join the conversation.

More
30 Jan 2021 18:27 #197171 by andypugh

Is there any advantage of now using the new 2.8.1 img? .


Not if what you have is working.

The changes include a kernel version that works with the variants that have no eeprom for the USB system and the 4GB limit pre-applied.
The following user(s) said Thank You: jfselcnc

Please Log in or Create an account to join the conversation.

More
01 Feb 2021 15:04 #197310 by bdp32
I hadn't seen that, I was still using 2.8.0, it worked fine with my earlier pi4...

Just found linuxcnc-2.8.1-pi4.img and it seems to work perfectly, thank you :)

Please Log in or Create an account to join the conversation.

More
03 Feb 2021 09:13 #197527 by twoflowers
I have just tested the SD image on my new RPi400. Lateny (Servo+base) is ~ 75000 as it comes out of the box.

Now I moved it from SD to a 8GB Kingston USB3 thumbdrive - write access is a bit on the slow side. I moved /var/tmp /tmp and /var/log to tmpfs, swapped from Debian to Devuan, killed anything GNOME and installed TDE. This brought latency down to 65000.

Now I disabled BT + WIFI + audio. Latency is <50000 after an hour testing.

Please Log in or Create an account to join the conversation.

More
03 Feb 2021 09:30 #197529 by andypugh

I have just tested the SD image on my new RPi400


_Which_ SD image?

I found that Linuxcnc-2.8.1-pi4.img didn't work on my Pi400.

Please Log in or Create an account to join the conversation.

Time to create page: 0.161 seconds
Powered by Kunena Forum