LinuxCNC Install using MX Linux 19.4 - Geared Toward New Users

More
26 Sep 2021 08:11 #221615 by tommylight
LinuxCNC seems to be using two keys, one for "base" and the other for buildbot.
Found out yesterday while giving Mint 20.2 another run with Master, it did not go well ... :(
The Python issue is becoming painful to sort out, and that brings another question for LinuxCNC masters: why does it require two pythons? Asks for python3.7 and after that is installed it keeps asking for just python <3.8 ?
Not the right place, i will kick myself out, thank you.
Will try MX today. :)

Please Log in or Create an account to join the conversation.

More
26 Sep 2021 09:34 #221622 by phillc54
The problem is that Buildbot uses Debian10 which builds for python3.7 as does MX19.
I think Mint20 uses python 3.8 so Buildbot LinuxCNC won't work, you would need to do run in place or make you own packages for Mint20 and anything else that doesn't have python3.7
I have package builds available for python3.9 if you want to use Debian11 or MX21. I am not sure what python version Mint 21? uses.
 
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
26 Sep 2021 09:52 #221623 by tommylight
Mint 20 came with Python 3.9, Mint 21 is not out yet nor have i seen any news about it (i was not looking for anyway).
Dang it, it was so easy ....

Please Log in or Create an account to join the conversation.

More
26 Sep 2021 10:07 #221624 by phillc54
Yeah it was easy when it was python2.7 as that was the last 2 version so every distro had 2.7.
I could have sworn the Mint20 I built had python 3.8

Please Log in or Create an account to join the conversation.

More
26 Sep 2021 14:46 #221638 by Clive S

It does. For deb and deb-src (which it looks like you may be missing, at least in the photo you provided) you need to edit the entry and change “stretch” to “buster”.


I decided to go with plan B and cloned the MXlinux drive and moved the config to it. Now its on the latest version

My next problem is the the bar at the bottom of the screen (task or panel) could do with auto hiding I haven't found the solution yet.

Please Log in or Create an account to join the conversation.

More
26 Sep 2021 15:13 #221641 by snowgoer540
Right click on the panel (and hold it), slide to Panel and then Panel Preferences, release right click.

In the Display tab, under General, there is a drop down next to "Automatically hide the panel:".  Never, Intelligently, Always

I am not sure what intelligently does, but either way, I think that is the option you are looking to change.

Glad to hear you got 'er goin!
The following user(s) said Thank You: Clive S

Please Log in or Create an account to join the conversation.

More
26 Sep 2021 17:02 #221645 by Clive S
Thanks Snowy.  That worked on the office machine  with MX will try tomorrow on the MX plasma  QT

Now I have 3 cloned drives and need to move a PlasmaC config over to QT I suppose I could manually just change all the pins in the hal and ini changes etc file over as I have QTplasmac on the drive.

The PlasmaC config is almost the same as mine just the Y axis is on different pins mesa 7i96

Please Log in or Create an account to join the conversation.

More
26 Sep 2021 17:05 #221647 by snowgoer540

Please Log in or Create an account to join the conversation.

More
26 Sep 2021 17:08 #221648 by Clive S

Phill’s got you covered on this one:

linuxcnc.org/docs/devel/html/plasma/qtpl...tml#qt_modify-config


Yes I did see that. I have asked my friend 70 miles away to send me his config so that I can set it up for him on my plasma.

I will give it a try.
The following user(s) said Thank You: snowgoer540

Please Log in or Create an account to join the conversation.

More
26 Sep 2021 17:14 #221649 by snowgoer540
No worries, both should work, so long as you catch all the important stuff.

If you are doing it for him, might be best to change the hal and ini files accordingly and send it back to him.  Then you wont have to deal with messed up symlinks.  
The following user(s) said Thank You: Clive S

Please Log in or Create an account to join the conversation.

Time to create page: 0.099 seconds
Powered by Kunena Forum