Install 2.9 on Debian 11

More
05 May 2022 12:18 #242032 by BigJohnT
Trying to update 2.9 to continue working on the 7i96S configuration but I'm running into issues.
Gdebi install button doesn't enable and there are a ton of linitan errors.
Trying to install from the command line with dpkg -i and I get these errors:
dpkg: dependency problems prevent configuration of linuxcnc-uspace:
 linuxcnc-uspace depends on python3 (<< 3.8); however:
  Version of python3 on system is 3.9.2-3.
 linuxcnc-uspace depends on libboost-python1.67.0; however:
  Package libboost-python1.67.0 is not installed.
 linuxcnc-uspace depends on libpython3.7 (>= 3.7.0); however:
  Package libpython3.7 is not installed.
 linuxcnc-uspace depends on libreadline5 (>= 5.2); however:
  Package libreadline5 is not installed.

Running sudo apt dist-upgrade failed and when I fix install linuxcnc-uspace is removed.

What a morning...

JT

Please Log in or Create an account to join the conversation.

More
05 May 2022 12:35 #242034 by BigJohnT
Replied by BigJohnT on topic Install 2.9 on Debian 11
For fun I tried to install 2.8.1 deb and I get:
Error: Dependency is not satisfiable: libboost-python1.67.0

JT

Please Log in or Create an account to join the conversation.

More
05 May 2022 15:09 #242044 by BigJohnT
Replied by BigJohnT on topic Install 2.9 on Debian 11
Running configure on a fresh pull of master I get:
checking for python... none
configure: error: python not found

JT

Please Log in or Create an account to join the conversation.

More
05 May 2022 21:03 #242067 by rodw
Replied by rodw on topic Install 2.9 on Debian 11
John, this seems a bit odd. Can you tell us how originally installed Debian Bullseye (11) ? Did you upgrade from Buster?
It looks a bit like you have had 2.8 running on your PC somehow in the past because of the Python version
dependency becasue of:
linuxcnc-uspace depends on python3 (<< 3.8); however:
  Version of python3 on system is 3.9.2-3.
Note Bullseye was upgraded to V 11.3 in March but I have never had any issues installing linuxcnc on a new build from source either using the recipe on the QTPYVCP web site or using Joco-nz's install script in his git
Bullseye uses Python 3.9 and Bookworm uses Python 3.10 and it installs on both for me.

You should not see that error unless possibly you have checked out V2.8. Its this dependency rubbish that made me adopt Bullseye and master branch when it was first released as it eliminated Python 2.7

Please Log in or Create an account to join the conversation.

More
06 May 2022 11:23 #242121 by BigJohnT
Replied by BigJohnT on topic Install 2.9 on Debian 11
I must have built a deb because a deb is building now.

In the debian directory:
./configure uspace

In the top most linuxcnc directory:
dpkg-buildpackage -b -uc

Odd I did have to satisfy a couple of dependencies for imagemagick and inkscape
sudo apt install imagemagick inkscape

JT
The following user(s) said Thank You: rodw

Please Log in or Create an account to join the conversation.

More
06 May 2022 11:39 #242122 by BigJohnT
Replied by BigJohnT on topic Install 2.9 on Debian 11
I did have to manually create the CNC menu but that's no big issue.

JT
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
06 May 2022 22:27 #242182 by Jalapeno56
Replied by Jalapeno56 on topic Install 2.9 on Debian 11
Not sure if I can help or hinder but.....I have debian 11 with Lcnc 2.9.0 running on a real time machine. Uspace would not work. I had to install -dev version to make things work properly.
forum.linuxcnc.org/plasmac/45743-thc-cannot-keep-up?start=30
Start at page 2

Please Log in or Create an account to join the conversation.

Time to create page: 0.255 seconds
Powered by Kunena Forum