Error while booting rpi4 / start4.elf: is not compatible

More
07 May 2022 07:25 #242213 by RMey
Hi, I'm new to linuxcnc and I have the following problem:

I have a 2gb rpi4 on which I'm trying to install linuxcnc 2.8.1. I'm using rpi-imager to flash the sd-card, no problems there. When I boot up the rpi I get this error "start4.elf: is not compatible", "this board requires newer software", (see picture). On some non linuxcnc forum on a similar case I found some advice to replace the start4.elf file in the rpi boot folder with the start4.elf file found in the boot folder of the rpi firmware found on github (github.com/raspberrypi/firmware). Trying to boot after this I get the error "Error, CPU 0 not supported!" (see picture), but it does boot up and I'm able to change my settings etc. On latency test I'm getting 50 000ns and as far as I'm concerned that's very high.

I'm quite lost right now so if I left out some important details just ask and I will provide them.
Attachments:
The following user(s) said Thank You: rdtsc

Please Log in or Create an account to join the conversation.

More
07 May 2022 09:25 #242223 by tommylight

On latency test I'm getting 50 000ns and as far as I'm concerned that's very high.

Not sure about the rest, but, 50K latency for a RPI is very, very good.

Please Log in or Create an account to join the conversation.

More
02 Oct 2022 18:13 - 17 Oct 2022 01:06 #253274 by rdtsc
Ditto, except mine goes to a black screen. The OS appears to be running, but nothing can be seen. Could be my "strange" Waveshare 18188 display. Tried "upgrading" other files but problems compounded.

Bottom line, the 1.75year-old RPi4 .iso is incompatible with my newer RPi4B firmware.

Edit: Volatile Rpi firmware compatibility (also volatile graphics support I hear) is making RPi compatibility difficult.  There are plenty of posts on how to update Rpi firmware, but very little on how to downgrade firmware.  I think firmware/video compatibility issues are why many Rpi newcomers end up in-over-their-head trying to build apps and kernels.  We need to state the required Rpi firmware version on every .iso created, and have a way to set it as such if it differs.
Last edit: 17 Oct 2022 01:06 by rdtsc. Reason: Built 5.19 RT 64-bit kernel, and it works! (only because of the current firmware...)

Please Log in or Create an account to join the conversation.

Time to create page: 0.080 seconds
Powered by Kunena Forum