Network Manager breaks newest version of linux cnc 2.8.4

More
16 Oct 2022 20:36 #254257 by smc.collins
Try running linux CNC with htm2 hotmot ethernet drivers. Latest version available for download will not allow cards to connect properly. 

hm2_eth : loading anyIO HostMot2 Ethernet driver version 0.2
hm2_eth : error : can't connect network is unreachable

I backed up to a version of 2.8 from sometime last year, problem is not present. 

Please Log in or Create an account to join the conversation.

More
16 Oct 2022 21:10 #254261 by tommylight
I am using 2.8.4 almost every day with several Mesa boards, not a single issue, yet.

Please Log in or Create an account to join the conversation.

More
16 Oct 2022 21:43 - 16 Oct 2022 21:46 #254267 by smc.collins
check latest version available for download. Works at 2.8.2 for me, but version 2.8.4 it will not connect.

Are you using  LinuxCNC V2.8.4-8-g6bd693e60

If not, what revision are you using. Also, how do you handle regression testing ? I'd like to track down the breakage, my suspicion is that it is coming from Debian. 
Last edit: 16 Oct 2022 21:46 by smc.collins.

Please Log in or Create an account to join the conversation.

More
16 Oct 2022 21:52 #254268 by tommylight
Will check tomorrow, not in the shop right now.
If it is the same one on the official ISO, that is what i have, i have not updated it since i installed it about two or three weeks ago.
The errors for sure point to wrong configuration or no connection/disabled network.
What does
ip a
return?

Please Log in or Create an account to join the conversation.

More
16 Oct 2022 22:59 - 17 Oct 2022 04:29 #254290 by smc.collins
Ok, I spent some time tracking down a few iso downloads 2.8.0, 2.8.2 and 2.8.4, none of these work out of the box at all using pncconf and any of the card combinations eluded too in the many threads here concerning the 7i97. For some reason, the rev 2.8.0 on my first conversion machine , which is kinda old now, works, and the only real difference I can figure it that it has MESA CT on it. But I can create working configurations from PNConf as well, by working I mean I can connect and communicate.. I also tried putting a few hardrives through the working machine with 2.8.0, nope, it is specifically that install that connects and works. The only thing I haven't done is put this machine online, and that shouldn't have ANY effect on LinuxCNC at all afaict. If putting this machine online during installs fixes it, full stop, the ISO's need repair. I should 100% be able to use and install linuxcnc and it's base OS with ZERO connection to the internet. 

So, this looks like a fragile software issue to me. There is some kind of fragility in the network stack, installer, linuxcnc or pnconf that is creating this problem. According to several threads, I should have been able to simply call the card a 7i92 with a 7i77 x on 7i77 in pnconf, and it should work. Lo and behold on the oldest drive I have this tatic does work. The fresh installs do not work.What odd is that I can get a network handshake, on the old install, but not even a clean install from the same CD that generated the original install.


The only real difference between any of these installs is that the Drives I am using are sata ssd, and the working drive is a platter spinner and also sata. I am at a loss here as to how to proceed. My regression tests are showing me that something is not right, the network is reporting no connection, but on my oldest install that doesn't seem to be a issue. I've read through all of the tutorials on configuring these cards and nothing seems to alleviate the problem at hand. 


 I am gonna have to make a decision about how to proceed here shortly. Maybe the answer is to simply abandon this damn card and goto a 7i77, I know they work, I know how to configure them and I can get moving asap. This fragility is very troubling, because I can't narrow down if this is a problem with Debian " which wouldn't really shock me at all" or a problem with linuxcnc.  I've lost 18 productive hours in 3 days on this. I think I am leaning towards a 7i77 and getting on with my life. The answer cannot be to endlessly bang on terminal scripts ,  configuration utilities, pinch here, poke there and adhoc this machine into working. I've read everything I can and nothing seems to offer a fix. 
Last edit: 17 Oct 2022 04:29 by smc.collins.

Please Log in or Create an account to join the conversation.

More
19 Oct 2022 00:54 - 19 Oct 2022 00:55 #254485 by smc.collins
the breakage occurred after version 2.8.0 with version 2.8.2 and up. I have now run this older install in multiple pc's and I can create stable ipv4 network connections to the 7i97. From what I can see in the change logs and there are many, the networking backend for many  drivers have changed since version 2.8.0 to force ipv6 connections. 


I ran out of time tonight to test this but I will setup a bench power supply and try to narrow down a solid permanent fix that can be put into a sticky somewhere so no one else has to endure this Fing madness . I think it could be more than just ipv6 at play, but my poking at the 2.8.4 install from my network shows even with ipv6 disabled in the network prefrences, it is still using ipv6 in the background completely ignoring my configuration changes in the network prefences panels. 

support.nordvpn.com/Connectivity/Linux/1...le-IPv6-on-Linux.htm
Last edit: 19 Oct 2022 00:55 by smc.collins.

Please Log in or Create an account to join the conversation.

Time to create page: 0.939 seconds
Powered by Kunena Forum