LinuxCNC on Debian Bookworm

More
26 Sep 2023 12:33 - 26 Sep 2023 12:34 #281645 by holziCNC
Hello everybody,I am facing the following fault during installation. I have reinstalled Python, so that may be a possible cause. Do you have any solutions for the problem?

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 linuxcnc-uspace : Depends: libboost-python1.67.0 but it is not installable
                   Depends: libpython2.7 (>= 2.7) but it is not installable
                   Depends: libreadline5 (>= 5.2) but it is not installable
                   Depends: python (>= 2.7) but it is not installable
                   Depends: python (< 2.8) but it is not installable
                   Depends: python:any (< 2.8) but it is not installable
                   Depends: python:any (>= 2.7~) but it is not installable
                   Depends: python2.7-tk but it is not installable
                   Depends: python2.7-glade2 but it is not installable or
                            python-glade2 but it is not installable
                   Depends: python2.7-numpy but it is not installable or
                            python-numpy but it is not installable
                   Depends: python2.7-imaging but it is not installable or
                            python-imaging but it is not installable or
                            python-pil but it is not installable
                   Depends: python2.7-imaging-tk but it is not installable or
                            python-imaging-tk but it is not installable or
                            python-pil.imagetk but it is not installable
                   Depends: python-gtksourceview2 but it is not going to be installed
                   Depends: python-gst-1.0 but it is not installable
                   Depends: python-xlib but it is not installable
                   Depends: python-gtkglext1 but it is not installable
                   Depends: python-configobj but it is not installable
                   Recommends: linuxcnc-doc-en but it is not going to be installed or
                               linuxcnc-doc
                   Recommends: python-pyqt5 but it is not installable
                   Recommends: python-pyqt5.qsci but it is not installable
                   Recommends: python-pyqt5.qtopengl but it is not installable
                   Recommends: python-pyqt5.qtsvg but it is not installable
                   Recommends: python-pyqt5.qtwebkit but it is not installable
                   Recommends: python-opencv but it is not installable
                   Recommends: python-rsvg but it is not going to be installed
                   Recommends: python-dbus.mainloop.pyqt5 but it is not installable
                   Recommends: python-espeak but it is not installable
                   Recommends: pyqt5-dev-tools but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Last edit: 26 Sep 2023 12:34 by holziCNC.

Please Log in or Create an account to join the conversation.

More
26 Sep 2023 15:04 #281654 by tommylight
How are we supposed to help you, you never mentioned what are you trying to install, and therein lies the issue, you are trying to install and older version of LinuxCNC that still uses Python 2.7 !!!
What version of BookWorm, there are several, what Desktop Environment, how are you trying to install whatever you are are trying to install, etc

Please Log in or Create an account to join the conversation.

More
26 Sep 2023 19:18 - 26 Sep 2023 19:19 #281660 by rodw
Replied by rodw on topic LinuxCNC on Debian Bookworm
Python 2.7 was deprecated in Debian 11 and  Bookworm is Debian 12.
Linuxcnc 2.8 uses Python 2.7. Therefore, you cannot run Linuxcnc 2.8 or earlier on bookworm.
You must run Linuxcnc 2.9 or higher which use Python 3.xx
In the stickies in this section, there is an ISO of bookworm that includes 2.9
Or you can follow the instructions in the v 2.9 getting started docs to install on an existing Debian 12 installation
Last edit: 26 Sep 2023 19:19 by rodw.
The following user(s) said Thank You: tivoi

Please Log in or Create an account to join the conversation.

Time to create page: 0.149 seconds
Powered by Kunena Forum