dpkg-shlibdeps: Error: no dependency information found for /usr/lib/libmodbus.so

More
31 Oct 2023 20:48 - 03 Nov 2023 09:33 #284216 by bkt
Unfortunately for my SO need to install version of Lcnc2.9 with python 2.7 ..... build package obtain these error ....
dpkg-shlibdeps: Error: no dependency information found for /usr/lib/libmodbus.so.5 (used by debian/linuxcnc-uspace/usr/bin/vfs11_vfd)

but not find any docs about libmodbus to install on mint 19.03 .... and if build a new version of libmodbus from libmodus git repo, not know where put it for make happy "dpkg-buildpackage -b -uc" command .... run in place install work perfect.

Warning: Spoiler!
Last edit: 03 Nov 2023 09:33 by bkt.

Please Log in or Create an account to join the conversation.

More
03 Nov 2023 09:32 #284422 by bkt
solution: install libmodbus 3.1.6 and use ldconfig ... these give you access to dependancy folder info as request from buildpackage ... than during dpkg-checkbuild.... if not install again libodbus-dev from repo ....

thats all folks !!

Please Log in or Create an account to join the conversation.

Time to create page: 0.102 seconds
Powered by Kunena Forum