Installing LinuxCNC in Fedora Linux on M1 Mac Mini using Asahi Linux

More
06 May 2024 21:19 #299969 by fully_defined
I just successfully installed LinuxCNC on my M1 Mac mini, although I don't own any compatible hardware yet so I can't vouch for the functionality. I first followed the procedures from asahilinux.org and typed the following into the MacOS Terminal app:

curl alx.sh | sh

After the boot I immediately updated it, which was about 1.6gb of updates, by first installing "Gnome Package Updater", which I found in the application launcher in the dock.

I then followed the directions from copr.fedorainfracloud.org/coprs/dwrobel/linuxcnc

However, their installation instructions were confusing (a Linux theme!), so here they are as I typed them:

sudo dnf install dnf-plugins-core

sudo dnf copr enable dwrobel/python-Yapps2

sudo dnf copr enable dwrobel/linuxcnc

sudo wget -O /etc/yum.repos.d/rt.repo dwrobel.fedorapeople.org/tmp/linuxcnc/rt.repo

sudo dnf install mirror.karneval.cz/pub/linux/centos-stre....0-23.el9.noarch.rpm

sudo dnf install linuxcnc-uspace --allowerasing

Here is the latency test right after installing LinuxCNC (sorry about the Moiré - I haven't figured out screenshots yet!): 

I thought I remembered seeing the letters RT in the latency test kernel the first time it ran, but now I don't see it. I have heard that the kernel (whatever a kernel even is!) does not necessarily boot (or whatever it does) the same way twice. As in, another kernel normally boots but the RT kernel did once just the first time for some reason. I don't know how to change that.

Next up I want to try it again, but with Debian, using git.zerfleddert.de/cgi-bin/gitweb.cgi/m1-debian/. It seems to use the Asahi installer but I don't remember seeing Debian as an option when I tried this so I anticipate failing the first time.

Either way, I am not totally committed to making LinuxCNC work on Apple hardware but if it can then I want to try! My end goal is to use Ethercat axis motors (currently using ClearPath SDSK) that are forthcoming from Technik, and so I need to switch to an Ethercat-compatible controller. I currently have EdingCNC on a PC and there is a lot I don't like about it.
Attachments:
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
11 May 2024 19:21 #300395 by tommylight
Fedora is being developed quite rapidly, about 4 months ago i gave it a try, the touchscreen stuff worked by far the best on it, but the boot time is still about 2-3times longer than Mint, and uses RPM while i am used to command line APT.
Still, knowing it works on it is satisfying, so thank you.

Please Log in or Create an account to join the conversation.

Time to create page: 0.166 seconds
Powered by Kunena Forum