Problems installing EMC2 with Xubuntu 8.04

More
30 Nov 2010 17:40 #5770 by lancewert
I recently installed Xubuntu on an older laptop with sucess. Seems to run very well (at least compared to Windows 98 it was running.)

I am now attempting to install EMC2 and am at a loss.

I have followed the instructions on this site and downloaded the EMCinstall.sh file. When I double click on the icon and message pops up telling me to input my password to install EMC2. After giving my password and pressing Enter nothing happens. I was thinking that maybe I have to be online or something....??

Anyway I am totally new at Linux and hope that its something obvious I am doing wrong.

Here are the specs on the laptop;

Gateway Solo 5300
Pentium 3 Mobile Edition 800Mhz
128 MB Ram
20 GB Hard Drive

Thanks

-Lance

Please Log in or Create an account to join the conversation.

More
30 Nov 2010 17:55 #5771 by BigJohnT
You might find some info here about non-standard installs...

wiki.linuxcnc.org/cgi-bin/emcinfo.pl?Installing_EMC2

While a few have succeeded typically real time applications like EMC2 are not installed on laptops as they generally make a poor candidate for real time due to power saving hardware in laptops. If your new to Linux why would you want to do a difficult install like trying to port Xbuntu to real time?

The simplest install is the LiveCD. The older one 8.04 might be a better bet for old hardware...

www.linuxcnc.org/docview/html//common_Getting_EMC.html

John

Please Log in or Create an account to join the conversation.

More
30 Nov 2010 20:07 - 30 Nov 2010 20:07 #5778 by lancewert
John-

Thanks for the info.

I initially tried to install Ubuntu 8.04 Live with EMC and the laptop would not install it. I tried multiple times and finally said screw it. I read a few posts with successful Xubuntu systems and decided to go this route.

-Lance
Last edit: 30 Nov 2010 20:07 by lancewert.

Please Log in or Create an account to join the conversation.

More
30 Nov 2010 23:57 #5788 by BigJohnT
Lance, in that case you might try installing Ubuntu 8.04.4 then installing the EMC sim. I had one motherboard that I had to go that route as the LiveCD came packaged with 8.04.0 and it missed a few things from the Ubuntu side of things I think.

wiki.linuxcnc.org/cgi-bin/emcinfo.pl?Ins...lding_emc2_simulator

John

Please Log in or Create an account to join the conversation.

More
01 Dec 2010 16:08 #5808 by step4linux
lancewert wrote:

I have followed the instructions on this site and downloaded the EMCinstall.sh file. When I double click on the icon and message pops up telling me to input my password to install EMC2. After giving my password and pressing Enter nothing happens. I was thinking that maybe I have to be online or something....??


Yes, you have to be online to use the script.
I did install the same like you describe on an old dell laptop with success some time ago.
After disabling SMI it works not bad.
I fear your RAM as bit low, you will not have that much fun with it.

Gerd

Please Log in or Create an account to join the conversation.

Time to create page: 0.076 seconds
Powered by Kunena Forum