Help on mother boards

More
31 Aug 2009 23:40 #763 by Rotaryeng
I have been trying for almost a week to get Ubuntu 804
version
of Ubuntu installed. I have at least 3 or 4 older mother
boards and half a dozen video cards. Apparently
Ubuntu is real picky about video chip sets.
I finally found an ATI video card that seems work.

"Basic Installation from one of the EMC2 Live CD's is easier and faster
than ever."

Well not exactly. I depends on how you save the image on a DVD
Fedora 8 Linux gives you an option. Image or file. If you choose
file it does not work. I found that out the hard way.

I find that Red Hat and Fedora are much easier to install
on a variety of hard ware. Ubuntu keeps you in the dark while it is
installing. There is nothing on the screen that tells you what, why or how
it is doing. After awhile you think the program has crashed and you hit
reset.

I have tried two versions so far. Ubuntu 804 and Ubuntu 9.04
They both appears to have the same problem on a variety of hardware.
EMC2 requires Ubuntu 804.

Also I suspect they do not like to install over other versions of Linux.

I bought Disk Purge to wipe an old Red Hat Linux drive clean and then used
Vicom Partition Commander to partition the disk and format it. That seemed
to help. No info in the instructions on the preferred file format so I
used Linux ext3 which may be a mistake.


I can highly recommends a $50, 1500 page book called Upgrading and
Repairing PCs.
by Scott Mueller. There is a Linux version out. This is a complete history
of the PC going back to early IBM's and all the variations of CPU's and
chip sets. There are many.

I almost have it working. The Ubuntu 804 is running off the DVD right at
the moment and trying to install itself on the hard drive. It takes
so long that I left it running in the hangar and will go back latter to
see
if it will boot from the hard drive.

Paul

Hi Paul,

You should be OK with ext3. The only thing a little inconvenient about
it is every 20 or 30 times you boot up it goes into a disk diagnostic
mode. Just go do something else for 10 or 15 minutes. You can cancel
out of it, but I figure having the file system checked every so often
isn't a bad thing.

I've been using Ubuntu for a couple of years now. I don't remember
having any particular problem loading it. I'm using an HP Pavilion
a630n with a 2.8 GHz Pentium processor and whatever video is built in
to it. Ubuntu makes it easy to keep all the software updated and so
far, I have never had a problem with any upgrade breaking the system.

It sounds like for your application you don't want updates anyway. If
you're not connected to the internet, updates aren't all that important.

Bob W.

--
N93BD - Rotary Powered BD-4 - www.bob-white.com
3.8 Hours Total Time and holding
Cables for your rotary installation - roblinstores.com/


After spending 3 hours installing the software I took the
disk out of the DVD drive and attempt to boot off the hard disk.
Grub loads and then I get ERROR 18............ nothing else!

What is ERROR 18?

Paul


Paul,

You said:

"I have tried two versions so far. Ubuntu 6.06 and Ubuntu 9.04a"

Have you tried the Ubuntu 8.04 / EMC2 live cd that you can get here:

www.linuxcnc.org/content/view/21/4/lang,en/

____________________________________?

This iso image is small enough to burn to a CD. I never tried burning it to
a DVD.

This version; Ubuntu 8.04 "Hardy Heron", is the version that I have been
using. I have not tried 6.06 Dapper Drake. The install screen usually keeps
you updated re: what is going on. If it goes blank for a long time, then
something is hanging the install process.

I had quite a few hangs while installing from the 8.04 live cd. It turned
out that I had a defective motherboard ( Gateway Profile w/ Pentium 4 ) so I
exchanged it for a Dell Precision 530 which worked just fine. These
computers were all available in my area (Albuquerque) from surplus shops for
under 100 bucks, who usually have a return policy.

You mentioned earlier that you had a Shuttle XPC. Why not give that one a
try?

Tom

I have not tried 8.04 yet.

Yes I am going through the same things.
I did a bios memory check and that seemed OK.
When I finally got Unbuntu Grub to boot off the hard disk
it said the memory was bad. The MB sat around for ten years
So the contacts may be corroded I fixed that and then the mem test would
run for 3 or 4 minutes and crash on the block moves. So I fixed that
and then it told me the clock was bad. Probably the battery as that
sat around for ten years as well. I can't believe a dead clock battery can cause
the kernal to crash but maybe the real time version uses the bat clock.
The voltage on the bat was .5 volts so that appears to be a real
possibility.

I'll get a new battery today and try it again.


BTW I bought a new DVD drive and that did not fix the ERROR 18.
That too seemed to be the bad mem.

I am using SOYO SY-K7 VIA mother board
with a 750 Mhz processor.

Model
SY-K7VIA
Description
- 200MHz System Interface Speed Slot-A Based VIA KX133 ATX Motherboard
Processor
- Single Slot-A for AMD-K7 Processor 500MHz ~800 MHz and faster
- 128Kbyte L1 cache built-in
- 512Kbyte L2 cache built-in
- 200MHz System interface Speed
Chipset
- VIA KX133 AGP chipset
System Memory
- Three 168-pin SDRAM 3.3V DIMM sockets support up to 1.5GB
- PC100/PC133 SDRAM support
- Provides ECC (Error Checking Correction) capability
Expansion Slots
- Five 32-bit Bus Mastering PCI slots (V2.2 compliant)
- One 16-bit ISA slots (one shared ISA/PCI slot)
- One AGP slot (v1.0 compliant, AGP 1X/2X/4X)
- One AMR (Audio Modem Riser) slot
On Board Ultra I/O Chip
- Chipset built-in I/O features
- Two RS-232 serial ports (16550 UART compatible)
- One parallel printer port (SPP/EPP/ECP mode)
- One FDD port (Supports LS120, 3 mode, 1.2/1.44/2.88 MB FDD
- Provides IrDA port with optional cable for transceiver
Ultra DMA 33 & 66 IDE Ports
- Two independent channels for four IDE devices
- Supports up to PIO Mode 4 and UDMA/66
- Two PCI bus mastering ATA E-IDE ports
Boot-Block Flash BIOS
- Award PCI BIOS with ACPI function
- Supports multiple-boot from E-IDE/ SCSI/ CD-ROM/ FDD/ LS120/ ZIP
- 2 Mbit Flash ROM
Board Dimensions
- Four layers, 30.5 cm x 22 cm(12" x 8.7")
- ATX form factor
Enhanced PC Health Monitoring
- On-board voltage monitors for +5V, +12V, VCORE, VTT and VBAT status
- System health status detect
- System temperature sensor
- CPU temperature monitoring through flexible thermal sensor under processor heatsink
Double Stack Back-Panel I/O Connectors
- PS/2 Mini-DIN mouse & keyboard ports
- Two USB ports
- Two D-Sub 9-pin male serial ports
- One D-Sub 25-pin female printer port
- Audio I/O: LINE-Outx1 , LINE-Inx1, MIC JACK x1
- One game port
--


I went out and spent $400 bucks on a new MegaByte mother board, processor
and memory. Guess what. Unbuntu refused to load.

In frustration a grabbed and old Fedora 5 and stuck it in the DVD drive.
Guess what? It loaded right off the bat with no problems.

Fedora install program is ten times better than Ubuntu keeping
you well informed on what it is doing, why it is doing what it is doing
and how long it is going to take. Unbuntu sometimes gives you a blinking cursor
and other times nothing and sometimes the light blinks on the DVD drive.

Fedora 5 also loaded on the board above with no problems.

BTW there is no need for half the stuff on the install distro.
Who is going to use open office on their NC mill computer?
If they removed half that useless stuff it would take a lot less time
to load and install.

Please Log in or Create an account to join the conversation.

More
02 Sep 2009 02:55 #771 by BMG
Replied by BMG on topic Re:Help on mother boards
Rotaryeng wrote:

Ubuntu keeps you in the dark while it is
installing. There is nothing on the screen that tells you what, why or how
it is doing. After awhile you think the program has crashed and you hit
reset.


There are two ways to go about loading EMC. THe first is to use the LiveCD which you have been tangling with. I too had issues initially when I first tried to load the CD. I had zero linux experience but had a smattering of dos and unix experience.

First off, when you load the CD, there is a splash screen that gives you several options. One of those is F6 i believe which allows you to modify the installation commands. Select that and look through the install command (its long). At the end, there is an option to remove called "Quiet splash" or something like that. That is Ubuntu's attempt to keep the install easy on first time users coming over from windows I suspect.

Removing that command will allow you to see the installation script as it proceeds enabling you to see where it hangs.

The second item I ran into was an issue with APIC. I placed the command -NOAPIC on that install command and the script then installed flawlessly. I was putting the cd onto an older box. As a matter of course, I use that command on every install (done 8-9 since).


There is an alternative method of installing EMC on a machine and that is by installing a regular version of UBUNTU 8.04 without EMC bundled. Get all your stuff loaded and running first, then use the method described on the website. This apparently is one user's recommendation when using touchscreens and other peripherals.

HTH's

Please Log in or Create an account to join the conversation.

More
02 Sep 2009 15:15 - 02 Sep 2009 15:24 #775 by Rotaryeng
Replied by Rotaryeng on topic Re:Help on mother boards
Thanks for the help.

I took that GigaByte mother board back and got my money back.
Worst mother board and BIOS I ever had the displeasure to use
in 30 years of building computers.

BTW the hot tip is to install Fedora first and let
it scope out the hard drive. It does a much better job.

Then install Ubuntu if you must :)

Paul


Paul,

Sorry to hear that you are having so much trouble loading Ubuntu.

I went to the Gmane linux emc users forum and typed in "grub error 18" and
got a lot of hits.

See here:
search.gmane.org/search.php?group=gmane....tributions.emc.user&
query=grub+error+18

I also found a debug trick that might help you, here is a partial quote from
one of the above web site hits:

"...when the system is first booting up, right after the
manufacturer's splash screen (if any), it says :
GRUB loading, please wait...

Hit ESC at that time, and you get a menu. Generally the last
item on the menu is the Memtest86 program, just hit the down
arrow key to highlight that entry and h it return. This
diagnostic will run forever if it finds no errors, otherwise it
will list what it has found wrong, at a fairly technical level.
But, what you are looking for is the presence or absence of
error reports. It may also be that your BIOS settings have
gotten corrupted, or that someone overclocked the computer for
gaming, and the settings are not correct for proper operation.
Most BIOS setup screens have some option to return all settings
to default, you might try that if you haven't made any special
settings for specific hardware compatibility."

Good luck,
Tom

Yes I did that Tom. That works for testing the memory.
One of the neat things about it is it times it self.
When I first used the SOYO board it would run for 12.5 minutes
and crash. Turned out there was a linear voltage regulator on
the board that was overheating and shutting down.
I dug up an old 115 volt 13 watt AC fan I had lying around
and applied that sledge hammer. Problem went away. I am looking
for a heat sink to glue to the top of the linear regulator chips.

That fan is ten times the power of your average 12 volt fan.

Paul

BTW guys that is a tiny pixel limit for attachments. You won't get
many at that size. This site would be more usefull with larger pictures.
Last edit: 02 Sep 2009 15:24 by Rotaryeng. Reason: pixel limit too small

Please Log in or Create an account to join the conversation.

More
02 Sep 2009 15:25 #776 by Rotaryeng
Replied by Rotaryeng on topic Re:Help on mother boards
Here is the pic of the fan.

Paul
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.086 seconds
Powered by Kunena Forum