Generic drive for Delta VFD C2000 plus with ethercat card CMC-EC01

More
28 Feb 2023 19:10 #265598 by diegojulio
Hello: I am trying to control my VFD delta C2000 plus with ethercat card CMC-EC01. When I run the ethercat slaves I can see the VFD, but when I run the ethercat slaves pdos, the VFD slave does not appear. Any sugestion? thanks in advance
Attachments:

Please Log in or Create an account to join the conversation.

More
28 Feb 2023 21:58 #265620 by db1981
Ethercat Modul CMC-E01 is the same as the modul in the MS300.
You can use the native ms300 driver.
But one Problem is the the manufacture delivers the drive with an faulty/empty SII Eeprom, so you have to burn the eeprom by yourself or load the content of the eeprom in the etherlab master (but this requieres a bit more experience....).

read at this thread.

forum.linuxcnc.org/ethercat/45099-trunca...-bit-signed-integers

Please Log in or Create an account to join the conversation.

More
01 Mar 2023 01:48 #265628 by diegojulio
Thanks for the information, Do you have a procedure to write the SII file into the CMC-EC01 card? Thanks in advance

Please Log in or Create an account to join the conversation.

More
01 Mar 2023 22:31 #265679 by diegojulio
Hello, I have PDOs from the Drive, and I put the in the XML file the configuration for the MS300. I can see the hal pins, but can not write the freq or the control word. I think my drive is a new version (C2000 plus) with the position control option. Maybe I need to write a different sii file in to the eprom. Any sugestion?

Please Log in or Create an account to join the conversation.

More
02 Mar 2023 09:58 #265706 by db1981
does the slave reaches ethercat op state after lcnc start?

As far as i know cmc-ec01 card is only for velocity command, for servo and position control there is the ec02 card.

do you have manufactur xml for c2000 with ec01 card?

Please Log in or Create an account to join the conversation.

Time to create page: 0.126 seconds
Powered by Kunena Forum