switching between world mode and joint mode

More
02 Aug 2020 04:06 #176858 by ericg
I have got my Mesa 5i25 card going well, I have gmocappy Going well (may swap back as I don't have a touchscreen) and I also have my HB04 pendant going mostly well, the only button that gives an error is the home all button which I like to use after a program is finished so the router is out of the way, however I get the error 'must be in joint mode to home' so the question is, how to I switch from world mode to joint mode? and is there a good explanation of these modes
This is the line in my xhc-HB04.hal file # Home button
net home halui.home-all <= xhc-hb04.button-home

Please Log in or Create an account to join the conversation.

More
02 Aug 2020 23:41 #176965 by tommylight
Moved to Gmoccapy section.

Please Log in or Create an account to join the conversation.

More
03 Aug 2020 03:49 #176995 by ericg
Sorry tommylight, wasn't sure where this question fitted

Please Log in or Create an account to join the conversation.

More
03 Aug 2020 08:01 #177009 by Aciera
What version of LinuxCNC are you using?
I use gmoccapy with linuxcnc master and also use an external button that connects to halui.home-all. Works fine for me.

Please Log in or Create an account to join the conversation.

More
03 Aug 2020 08:16 - 03 Aug 2020 08:17 #177012 by ericg
from uname -a I get..
Linux linuxcnc 4.19.0-9-rt-amd64 #1 SMP PREEMPT RT Debian 4.19.118-2+deb10u1 (2020-06-07) x86_64 GNU/Linux

Is linuxcnc Master something I should have?

what is the specific command you use? mine is from xhc-hb04.hal
# Home button
net home halui.home-all <= xhc-hb04.button-home
thanks for the response
Last edit: 03 Aug 2020 08:17 by ericg. Reason: added some info

Please Log in or Create an account to join the conversation.

More
03 Aug 2020 08:41 #177019 by tommylight

Sorry tommylight, wasn't sure where this question fitted

No worries, all good, also wanted to bump it up as no one answered.

Please Log in or Create an account to join the conversation.

More
11 Aug 2020 20:44 #177942 by newbynobi
If you have kinstype=Both in you INI config you should see a button to switch the joint world mode.
If you have keyboard handling enabled on the setting page, F12 should change modes.

If you post your config folder, I can check for config errors.

Norbert

Please Log in or Create an account to join the conversation.

More
04 Mar 2023 11:25 #265834 by HansU
Like this:
[KINS]
KINEMATICS = trivkins coordinates=xyz kinstype=BOTH 
JOINTS = 3

I mention it here, because it is currently not really mentioned in the documentation.

Please Log in or Create an account to join the conversation.

Moderators: newbynobiHansU
Time to create page: 0.202 seconds
Powered by Kunena Forum