2.9.0-pre0-4388-gc2838822c / Gmoccapy >> Py 3 // gladevcp/iconview.py

More
07 Aug 2021 11:02 #217115 by robertspark
2.9.0-pre0-4388-gc2838822c

somewhere between Gmoccapy (the change to Python 3) and the file gladevcp/iconview.py

there is an error loading Gmoccapy

(bit better / more detailed explanation in the attached report)

 

File Attachment:

File Name: linuxcnc_2...8-07.txt
File Size:16 KB

Traceback (most recent call last):
  File "/usr/bin/gmoccapy", line 5299, in <module>
    app = gmoccapy(sys.argv)
  File "/usr/bin/gmoccapy", line 328, in __init__
    self._init_IconFileSelection()
  File "/usr/bin/gmoccapy", line 2101, in _init_IconFileSelection
    self.widgets.IconFileSelection1.show_filelabel(False)
  File "/usr/lib/python3/dist-packages/gladevcp/iconview.py", line 404, in show_filelabel
    self.file_label.hide()
AttributeError: 'IconFileSelection' object has no attribute 'file_label'

(gmoccapy:10763): Gtk-WARNING **: 11:54:29.634: Invalid icon size 48
(gmoccapy:10763): Gtk-WARNING **: 11:54:29.636: Invalid icon size 48
/usr/bin/gmoccapy:717: PyGTKDeprecationWarning: Using positional arguments with the GObject constructor has been deprecated. Please specify keyword(s) for "label" or use a class specific constructor. See: wiki.gnome.org/PyGObject/InitializerDeprecations
  lbl = Gtk.Label("")
/usr/bin/gmoccapy:735: DeprecationWarning: Gtk.Image.set_from_stock is deprecated
  image.set_from_stock(stock, 48)
/usr/bin/gmoccapy:896: PyGTKDeprecationWarning: Using positional arguments with the GObject constructor has been deprecated. Please specify keyword(s) for "label" or use a class specific constructor. See: wiki.gnome.org/PyGObject/InitializerDeprecations
  btn = Gtk.ToggleButton(_("  edit\noffsets"))
/usr/bin/gmoccapy:900: DeprecationWarning: Gtk.Widget.modify_bg is deprecated
  btn.modify_bg(Gtk.StateFlags.ACTIVE, Gdk.color_parse("#FFFF00"))
/usr/bin/gmoccapy:944: PyGTKDeprecationWarning: Using positional arguments with the GObject constructor has been deprecated. Please specify keyword(s) for "label" or use a class specific constructor. See: wiki.gnome.org/PyGObject/InitializerDeprecations
  btn = Gtk.Button(_("zero\n G92"))
/usr/bin/gmoccapy:959: PyGTKDeprecationWarning: Using positional arguments with the GObject constructor has been deprecated. Please specify keyword(s) for "label" or use a class specific constructor. See: wiki.gnome.org/PyGObject/InitializerDeprecations
  btn = Gtk.Button(_("    set\nselected"))
/usr/bin/gmoccapy:1168: PyGTKDeprecationWarning: Using positional arguments with the GObject constructor has been deprecated. Please specify keyword(s) for "label" or use a class specific constructor. See: wiki.gnome.org/PyGObject/InitializerDeprecations
  btn = Gtk.Button(name.upper())
/usr/bin/gmoccapy:1374: DeprecationWarning: Gtk.Table.resize is deprecated
  self.widgets.tbl_jog_btn_axes.resize(3,3)

(gmoccapy:10763): Gtk-WARNING **: 11:54:30.499: Invalid icon size 48
(gmoccapy:10763): Gtk-WARNING **: 11:54:30.500: Invalid icon size 48
(gmoccapy:10763): Gtk-CRITICAL **: 11:54:32.134: gtk_text_buffer_remove_tag: assertion 'tag->priv->table == buffer->priv->tag_table' failed
(gmoccapy:10763): Gtk-CRITICAL **: 11:54:32.135: gtk_text_buffer_remove_tag: assertion 'tag->priv->table == buffer->priv->tag_table' failed
(gmoccapy:10763): Gtk-WARNING **: 11:54:32.267: Invalid icon size 48
(gmoccapy:10763): Gtk-WARNING **: 11:54:32.268: Invalid icon size 48
(gmoccapy:10763): Gtk-WARNING **: 11:54:32.389: Invalid icon size 48
(gmoccapy:10763): Gtk-WARNING **: 11:54:32.390: Invalid icon size 48
(gmoccapy:10763): Gtk-WARNING **: 11:54:32.594: Invalid icon size 48
(gmoccapy:10763): Gtk-WARNING **: 11:54:32.594: Invalid icon size 48


 
Attachments:

Please Log in or Create an account to join the conversation.

More
07 Aug 2021 16:55 #217140 by cmorley
Can you give info on your operating system?
Have you modified anything?
is this error present on sim configs?
Does the error show right away or do you do something to invoke it?

I do not see this error - nor how it could happen. I use mint 20 though

Please Log in or Create an account to join the conversation.

More
07 Aug 2021 17:38 #217146 by robertspark
Buster installed via 2.8.1 iso and kept up to date via sudo apt update & sudo apt upgrade.

Linuxcnc kept up to date via buildbot to master, daily updated.

Yes the error is apparent on sim and my configs.

No, I do not believe that I have modified anything, but anything is a bit of a wide sweeping statement...... as I obviously have other applications installed such as sheetcam, estlcam via play on linux.

Yes the error shows up at the time of loading.

I am going to back up my configs, wipe and install fresh from 2.8.2 iso shortly.

I will report back, as I "should" just be able to install from clean iso install..... change to buildbot master .... and 2.9 + gmoccapy via configs should work.....

I have removed nativeCAM for the time being.

I will report back later.

Please Log in or Create an account to join the conversation.

More
07 Aug 2021 18:21 #217147 by cmorley
hmm I think Debian buster might be too old.
I'm not sure what the minimum python3/GTK3 version is.

So you are not compiling - you are using buildbot binaries?

I had a little trouble compiling linuxcnc on mint 19 - had to backport python-yapps2 (unrelated to your problem)

Chris

Please Log in or Create an account to join the conversation.

More
07 Aug 2021 21:26 #217158 by robertspark
I've just clean reinstalled from linuxCNC 2.8.2 iso vi usb stick (debian).

changed sources to buildbot master, and updated

created new Gmoccapy Sim (lathe) and was given the same message

Please Log in or Create an account to join the conversation.

More
08 Aug 2021 01:44 #217171 by phillc54
I can successfully run all the Gmoccapy sims using the same Buildbot version, 2.9.0-pre0-4388-gc2838822c. The only difference is that I use MX-Linux19.3 but that is based on Buster so should act similar.
I do get a lot of deprecation warnings but no errors.

Please Log in or Create an account to join the conversation.

More
08 Aug 2021 07:45 #217188 by rodw
The error seems to be higher in the file
Traceback (most recent call last):
  File "/usr/bin/gmoccapy", line 5299, in <module>
    app = gmoccapy(sys.argv)
  File "/usr/bin/gmoccapy", line 328, in __init__
    self._init_IconFileSelection()
  File "/usr/bin/gmoccapy", line 2101, in _init_IconFileSelection
    self.widgets.IconFileSelection1.show_filelabel(False)
  File "/usr/lib/python3/dist-packages/gladevcp/iconview.py", line 404, in show_filelabel
    self.file_label.hide()
AttributeError: 'IconFileSelection' object has no attribute 'file_label'

G-Code error in ncam.ngc
Near line 103 of
/home/rob/linuxcnc/configs/Lathe-GMO/ncam/scripts/ncam.ngc
EOF in file:/home/rob/linuxcnc/configs/Lathe-GMO/ncam/scripts/ncam.ngc seeking o-word: o<select> from line: 102

Note the python error, I'm not sure of a solution. I'll try a gmocappy sim on my build of V2.9 I compiled today
The following user(s) said Thank You: robertspark

Please Log in or Create an account to join the conversation.

More
08 Aug 2021 07:54 #217189 by rodw
Actually a Gmoccapy SIM is perfectly well behaved here based on todays code base when Running on Debian Bullseye.
I was going to post up a howto when I have a bit of time (2 days playing with this over the weekend has left me a bit worn out
Bullseye is to be release as final in < 1 week and includes preempt_rt
Warning: Spoiler!
The following user(s) said Thank You: robertspark

Please Log in or Create an account to join the conversation.

More
16 Sep 2021 15:49 #220803 by rider-83
I have exactly the same problem.
I updated my ver2.9 to the latest and gmoccapy completely stopped functioning with all the same errors as stated at the top of this thread

Please Log in or Create an account to join the conversation.

More
16 Sep 2021 18:16 #220806 by robertspark
did you find the fix?

I found what was missing in another thread.... I did a bit of investigation.

forum.linuxcnc.org/gmoccapy/43477-gmoccapy-theme#219291

Also there are a list of dependencies that you may need to install too to clear some of the issues.

forum.linuxcnc.org/9-installing-linuxcnc...eye-questions#220493
The following user(s) said Thank You: Aciera

Please Log in or Create an account to join the conversation.

Moderators: newbynobi
Time to create page: 0.107 seconds
Powered by Kunena Forum