When Linux CNC runs G code, the X axis has only one direction

More
18 Nov 2021 16:55 #226892 by tuzki
Hello everyone.

Today I use LinuxCNC to run the sample G code. I found that LinuxCNC has only one direction on the X axis during operation, and it cannot correctly execute the positive and negative directions in the G code.

When I am not running the G code, I use the GUI to manually move the X axis, and the X axis works normally.

The parallel port control board I use controls an X axis. There is no motor connected to the Y-axis and Z-axis, because I only have a stepper motor.

I use gmoccapy GUI.

I don't know where is the problem. Can someone help me.   thanks.
 

Please Log in or Create an account to join the conversation.

More
18 Nov 2021 17:10 #226893 by BigJohnT
Sounds like your G code is faulty. A sample of what your running would help.

JT

Please Log in or Create an account to join the conversation.

More
18 Nov 2021 17:19 #226894 by tuzki
correct. I changed other sample G codes, some of the directions are not processed normally, and some are normal

I will record the G codes that I can't run normally and send them to the forum. Maybe it is normal when other people run these G codes.q(≧▽≦q)

Please Log in or Create an account to join the conversation.

More
19 Nov 2021 17:23 #227003 by tuzki
Today, I tried the programs that had problems yesterday, and I found that the programs that have problems can run normally.

Kind of weird

Please Log in or Create an account to join the conversation.

Moderators: newbynobi
Time to create page: 0.103 seconds
Powered by Kunena Forum