Buidling LCNC 2.8.2 RIP - with Gmoccapy

More
22 Jun 2022 06:33 #245579 by zz912
Hello,

I built LCNC RIP 2.8.2 for Raspbian 10 yesterday.
Raspbian from LCNC did not work for my version Raspberry (I dont know why), so I had to use natural Raspbian.

I used this website:
linuxcnc.org/docs/stable/html/code/building-linuxcnc.html

If I used only this instructions, Gmoccapy dont work, only Axis.

I have to:
sudo apt-get install \build-essential devscripts dh-make \
intltool python-gtk2-dev \
libxml2-dev \
gtk-doc-tools \
gnome-doc-utils \
liblablgtk2-gnome-ocaml-dev \
libglade2-dev \
libgladeui-common \
python-gtkglext1 \
devhelp \
itstool \
libcanberra-gtk-module \
libcanberra-gtk-dev
sudo apt-get install \
devscripts \
tcl8.6-dev tk8.6-dev \
libreadline-gplv2-dev \
asciidoc dblatex \
dvipng graphviz groff \
imagemagick inkscape \
python-lxml source-highlight \
texlive-extra-utils \
texlive-font-utils \
texlive-fonts-recommended \
texlive-lang-cyrillic \
texlive-lang-french \
texlive-lang-german \
texlive-lang-polish \
texlive-lang-spanish \
texlive-latex-recommended \
w3c-linkchecker \
xsltproc \
libxmu-dev \
libglu1-mesa-dev libgl1-mesa-dev \
libboost-python-dev \
libmodbus-dev \
libusb-1.0-0-dev python-serial \
yapps2 \
asciidoc-dblatex \
libxaw7-dev

Source: 
forum.linuxcnc.org/9-installing-linuxcnc...lade-linuxcnc#112162

and
sudo apt-get install python-gtksourceview2

Is possible this package add to /home/pi/LinuxCNC/linuxcnc-2.8.2/debian/configure ?

Or exist some reason why not?

Please Log in or Create an account to join the conversation.

More
22 Jun 2022 23:55 #245630 by andypugh
Many of these packages would normally be installed as dependencies of packages which are already in

github.com/LinuxCNC/linuxcnc/blob/master/debian/control.top.in
github.com/LinuxCNC/linuxcnc/blob/master.../control.main-pkg.in


It's not trivial to work out which need to be mentioned individually, but we have checked that the current list works on the buildbot platforms.

Please Log in or Create an account to join the conversation.

More
23 Jun 2022 12:50 #245676 by zz912

but we have checked that the current list works on the buildbot platforms.

Did you check with Gmoccapy? With AXIS it worked.

Please Log in or Create an account to join the conversation.

More
23 Jun 2022 23:37 #245742 by andypugh
At least one Gmoccapy config has been tested

github.com/LinuxCNC/linuxcnc/issues/1762

Please Log in or Create an account to join the conversation.

More
24 Jun 2022 12:48 #245777 by HansU
If I understand you correctly, it works now for you after you have installed the dependencies you listed?

Please Log in or Create an account to join the conversation.

More
29 Jun 2022 07:36 #246139 by zz912

If I understand you correctly, it works now for you after you have installed the dependencies you listed?

Exactly. 

Please Log in or Create an account to join the conversation.

More
29 Jun 2022 07:39 #246140 by zz912

At least one Gmoccapy config has been tested

github.com/LinuxCNC/linuxcnc/issues/1762

But I want use LCNC 2.8. There is Python 2. Idont know what do you mean with this test. 

Please Log in or Create an account to join the conversation.

More
08 Jul 2022 13:55 #246862 by zz912

but we have checked that the current list works on the buildbot platforms.

 
Your check have bug, or I do something that no one expects. (The second way is often :-) )

I made another RIP Instalation with normal Debian not RPI Debian
zdenek@CNC:~$ uname -a
Linux CNC 4.19.0-21-rt-amd64 #1 SMP PREEMPT RT Debian 4.19.249-2 (2022-06-30) x86_64 GNU/Linux
And I needed install the packages, which I mentioned at the beginning too.
I don't know if I need them all, but I'd rather have some extra packages than have LCNC not work for me.

I downloaded Live CD 2.8, and made bootable flash disk. I installed the flash disk. I "apt-get remove" all package with name *linuxcnc*. I installed RIP LCNC 2.8 linuxcnc.org/docs/stable/html/code/building-linuxcnc.html

Now LCNC 2.8 works. BUT only with AXIS or another GUI. Now LCNC 2.8 with Gmoccapy DONT works.

Then I install package which I mentioned at the beginning and LCNC 2.8 with Gmoccapy works.

It's not a problem for me. when i know this problem. But it might discourage someone who wants to start exploring the LCNC source code. What can I do to fix this error systemically?

I have another free PC where I can do some other test that would help you, but I need to know what would help you.

The easiest way is added the packages here:
linuxcnc.org/docs/stable/html/code/building-linuxcnc.html
OR?

Please Log in or Create an account to join the conversation.

More
08 Jul 2022 15:20 - 09 Jul 2022 20:35 #246868 by zz912
This is some discusion in Facebook.
 
For RIP 2.8 you must known this reporitories.
Attachments:
Last edit: 09 Jul 2022 20:35 by zz912.

Please Log in or Create an account to join the conversation.

More
13 Jul 2022 22:30 #247259 by andypugh
The current run-time dependencies (from debian/control) are:

Depends:
${misc:Depends},
${python3:Depends},
${shlibs:Depends},
libudev-dev,iptables,
blt,
mesa-utils,
python3-tk,
python3-numpy,
python3-cairo,
python3-gi-cairo,
python3-opengl,
python3-configobj,
python3-xlib,
libgtksourceview-3.0-dev,
tcl8.6,
tk8.6,
bwidget (>= 1.7),
tclreadline,
tclx,
procps, psmisc,
udev
Recommends:
linuxcnc-doc-en | linuxcnc-doc,
librsvg2-dev,
hostmot2-firmware-all, linux-image-rt-amd64 [linux-amd64], linux-image-rt-686-pae [linux-i386],
python3-pil,
python3-pil.imagetk,
python3-pyqt5,
python3-pyqt5.qsci,
python3-pyqt5.qtsvg,
python3-pyqt5.qtopengl,
python3-opencv,
python3-dbus,python3-espeak,
python3-dbus.mainloop.pyqt5,
python3-pyqt5.qtwebkit,
python3-xlib,
espeak-ng,python3-numpy,
pyqt5-dev-tools,
gstreamer1.0-tools,espeak,
sound-theme-freedesktop
Suggests: mesaflash


The build-time dependencies are the above, and additionally:

Build-Depends:
debhelper (>= 9),
dh-python,
libudev-dev,
autoconf,
bwidget (>= 1.7),
desktop-file-utils,
gettext,
intltool,
libboost-python-dev,
libepoxy-dev,
libgl1-mesa-dev | libgl1-mesa-swx11-dev,
libglu1-mesa-dev,
libgtk2.0-dev,
libgtk-3-dev,
libmodbus-dev (>= 3.0),
libreadline-gplv2-dev | libreadline-dev,
libtirpc-dev,
libusb-1.0-0-dev,
libxmu-dev,
netcat,
po4a,
procps,
psmisc,
python3,
python3-dev,
python3-tk,
python3-xlib,
tcl8.6-dev,
tclx,
tk8.6-dev,
yapps2
Build-Depends-Indep:
asciidoc (>= 8.5),
dblatex (>= 0.2.12),
docbook-xsl,
dvipng,
ghostscript,
graphviz,
groff,
imagemagick,
inkscape,
python3-lxml,
source-highlight,
w3c-linkchecker,
xsltproc,
texlive-extra-utils,
texlive-font-utils,
texlive-fonts-recommended,
texlive-lang-cyrillic,
texlive-lang-french,
texlive-lang-german,
texlive-lang-polish,
texlive-lang-spanish,
texlive-latex-recommended,
asciidoc-dblatex,
texlive-xetex,
Standards-Version: 4.6.0
Vcs-Browser: github.com/LinuxCNC/linuxcnc
Vcs-Git: github.com/LinuxCNC/linuxcnc.git
Rules-Requires-Root: binary-targets

Package: linuxcnc-uspace-dev
Architecture: any
Conflicts: linuxcnc-sim-dev, linuxcnc-dev
Depends: ${misc:Depends},
${python3:Depends},
python3-serial,
linuxcnc-uspace (= ${binary:Version}),
udev,
python3-yapps


Many of the latter will be installed in one go with
apt-get install build-essential

Please Log in or Create an account to join the conversation.

Moderators: newbynobi
Time to create page: 0.177 seconds
Powered by Kunena Forum