m3 command capped at 6000 RPM for first execution from off, then any speed works

More
16 Feb 2023 23:34 #264672 by trainwreck
Hello everyone,

I have a very strange issue that I did search the forums for and couldn't find anything that seemed similar. I'm using Gmoccapy as my UI and have a YL620 VFD configured using VFDMOD. The setup works, but there's a strange issue where when I issue the first m3 sXXXX command (either the first after turning on the machine, or first since the last m5) the GUI will flash the speed I input and then immediately drop to 6000 RPM, and the spindle beings spinning at 6000 RPM. After that, any m3 commands work as you would expect. Alternatively, if I send any speed lower than 6000RPM for the first m3 it will correctly use the value as sent.

The above makes me think that there is some kind of weirdness making linuxcnc think that 6000RPM is the max possible RPM and so it clips anything above that, but if that were the case I don't understand why any following m3 commands would work as expected.

I have attached all of my hal files, as well as the ini file for VFDMOD and the xml file for the pyvcp spindle panel just in case that is somehow related. Any help would be greatly appreciated!

Please Log in or Create an account to join the conversation.

More
18 Feb 2023 23:02 #264777 by RobC
In your custom.hal file, add a -d after vfd.ini, like this:

loadusr -W vfdmod vfd.ini -d

Then you can run linuxcnc from terminal and you should be able to see the vfdmod comms. It will probably be sending 666 or 667 by default to set your min speed of 4000 rpm. When you issue MDI command for some other speed you should be able to see in the terminal if vfdmod sends the command speed like it should, or if it sends something else.

Since it works generally, I suspect vfdmod is fine. I browsed the yalang manual and didn't see anything about a start frequency, but it could be something like that. Apart from that, the only thing I see in your files that I don't have is this section at the bottom of your printnc.ini:

[SPINDLE_0]
P = 0
I = 0
D = 0
FF0 = 1
FF1 = 0
FF2 = 0
BIAS = 0
DEADBAND = 0
MAX_OUTPUT = 2000

I don't have mesa (or experience with them at all) but I assume those settings are from there. Not sure if any of those could interfere since you are using USB / RS485 for control?

Please Log in or Create an account to join the conversation.

More
20 Feb 2023 14:51 #264865 by trainwreck
Thanks for your reply! I was out of town all weekend, but I'm back now so I'll give your suggestion a try and see what the output looks like. Will update with results.

Please Log in or Create an account to join the conversation.

More
21 Feb 2023 01:11 #264930 by trainwreck
So I removed the SPINDLE_0 block from my ini file and also included the -d in my vfdmod load. Unfortunately the output is so ridiculously noisy that I couldn't really learning anything from it. Is there a way to prune some of the output?

Please Log in or Create an account to join the conversation.

More
21 Feb 2023 17:40 #264970 by RobC
Probably the easiest way would be to open linuxcnc normally, home, and then issue an M3 S7000 (or any other number above 6k). The TargetFrequency in the spindle panel will show whether vfdmod has changed the target down to 100.0, or if it's stayed at the original / commanded frequency.

Please Log in or Create an account to join the conversation.

More
21 Feb 2023 21:15 - 21 Feb 2023 22:16 #264983 by RobC
I was looking at your manual and saw the acceleration time setting - PD014. shows it being 8 by default. That being too high could cause it to not get up to speed and default to 6k rpm. Try lowering a bit and see if that makes any difference.

-- edit: PD014 is for the other vfd printnc uses. Looks like you accel settings start at PD06.00
Last edit: 21 Feb 2023 22:16 by RobC. Reason: More info

Please Log in or Create an account to join the conversation.

More
23 Mar 2023 01:52 #267341 by trainwreck
Hi Rob,

I'm sorry I let this thread go unanswered for so long! Family life got in the way - we had a tree fall our house :( - and on top of that I somehow burned out the VFD that I was using and had to replace it. I now have a Durapulse GS10 and am oddly still seeing the same behavior. Even more oddly, when I run a program that includes m3 commands they work just fine regardless of the speed. Somehow, this 6000 rpm limit only appears to apply to the MDI and manual windows of gmoccapy.

Please Log in or Create an account to join the conversation.

More
24 Mar 2023 18:23 #267410 by HansU
Have you checked the hardware settings page of Gmoccapy?
Per default the spindle speed is limited there to 6000 rpm: linuxcnc.org/docs/2.9/html/gui/gmoccapy.html#_hardware
The following user(s) said Thank You: trainwreck

Please Log in or Create an account to join the conversation.

More
24 Mar 2023 19:27 #267414 by snowgoer540
Topic moved to gmoccapy per HansU's request.
The following user(s) said Thank You: HansU

Please Log in or Create an account to join the conversation.

Moderators: newbynobiHansU
Time to create page: 1.082 seconds
Powered by Kunena Forum