MAcro buttons in MDI will not show

More
02 May 2023 21:36 #270508 by CNCGOOS
Hello All,

i have read a lot about the useage of Macro Buttons in the Mode MDI 
Current versin LCNC 2.8.4
Current version GMOCAPPY 3.1.3.8

I woud like tu use macros buttons in the MDI mode.
what do i Wrong in the ini file or ngc file, both add in this message 
Attachments:

Please Log in or Create an account to join the conversation.

More
03 May 2023 07:22 - 03 May 2023 12:50 #270542 by 0x2102
Changed, due to misleading information....
Last edit: 03 May 2023 12:50 by 0x2102.

Please Log in or Create an account to join the conversation.

More
03 May 2023 07:23 #270543 by HansU
Two things I notice:

1. SUBROUTINE_PATH: "The list must contain no intervening whitespace." So remove the spaces. You can also try to remove the part after the colon, shouldn't be needed.

2. (msg, diameter circel is #1) --> (msg, diameter circel is [#1])

If that doesn't help have a look at the gmoccapy sim config:
github.com/LinuxCNC/linuxcnc/blob/2.8/co...moccapy/gmoccapy.ini
github.com/LinuxCNC/linuxcnc/blob/2.8/co...macros/increment.ngc

Please Log in or Create an account to join the conversation.

More
03 May 2023 07:46 #270544 by CNCGOOS
Thanks you both, 

i wil try the sugestions and let it know if it works.

Please Log in or Create an account to join the conversation.

More
03 May 2023 08:51 #270545 by CNCGOOS
i have changed it all but nothing will 
appears in the bottom Row. as shown in the Picture. 
What did I forget to set that the macros appear in the bottom bar

file name is the same as marco name and also the name in the ini. all lowercasse

 
Attachments:

Please Log in or Create an account to join the conversation.

More
03 May 2023 09:27 #270546 by HansU
Try to modify the sample config step by step.

Please Log in or Create an account to join the conversation.

More
03 May 2023 10:56 #270549 by CNCGOOS
Thanks HansU,

i found it there was still somting wrong in the link to the files

it wil function now well. and i can make more usefull Macro's

Please Log in or Create an account to join the conversation.

More
03 May 2023 12:47 #270562 by 0x2102
Sorry, please ignore what I said before, to remove "diameter" this is actually the parameter it asks you for when you run the script.

My macro icons disappear when I rename my macro folder (did this as a test). So I assume your search path was/is not correct in your INI.

Please Log in or Create an account to join the conversation.

More
03 May 2023 12:59 #270563 by HansU
So what exactly was the error? Would be good to know for other users who might land here.

Please Log in or Create an account to join the conversation.

More
03 May 2023 13:24 #270565 by CNCGOOS
I have to do it like this
SUBROUTINE_PATH = /home/joost/linuxcnc/nc_files/macros

SUBROUTINE_PATH = macros
was not working
just like this
(IMAGE,./macros/Button_Image/cirkel_binnen.png)

i have change it to the next row

(IMAGE,/home/joost/linuxcnc/nc_files/macros/Button_Image/cirkel_binnen.png)

Please Log in or Create an account to join the conversation.

Moderators: newbynobiHansU
Time to create page: 0.091 seconds
Powered by Kunena Forum