Lathe backplot reversed

More
26 Apr 2016 19:09 - 26 Apr 2016 19:22 #73929 by mariusl
How do I get the lathe backplot to display my tool paths on the front of the spindle. The tool shows in the right direction but the tool paths are at the back.

And now I wonder, where will the tool be cutting from, also the back?

Regards
Marius


www.bluearccnc.com

Last edit: 26 Apr 2016 19:22 by mariusl.

Please Log in or Create an account to join the conversation.

More
26 Apr 2016 23:50 #73939 by joekline9
Replied by joekline9 on topic Lathe backplot reversed
I use front and back tools. I don't do anything with the axis.rc file.

I use G10 L2 R0 and G10 L2 R180 to rotate the coordinate system around the Z axis.
The same g76 parameters are used whether front or back.
The tools display correct but you need different orientation & angles for the back tools.

Tool Defs:
P is Tool No. I & J are angles, Q is orientation.

G10 L1 P4 R.002 I120 J60 Q6 (Front tool)
G10 L1 P7 R.002 I-120 J-60 Q8 (Back tool)

X positive numbers are always from the center of the part.

See:
Lathe-g76-Front-Back.ngc

I hope this helps.
Attachments:

Please Log in or Create an account to join the conversation.

More
27 Apr 2016 06:50 #73943 by mariusl
Replied by mariusl on topic Lathe backplot reversed
I dont have back tools so I will always be in the x positive area. I am busy setting up my lathe with PP and as soon as I have it running I will test your solution. Thanks for the info.

Regards
Marius


www.bluearccnc.com

Please Log in or Create an account to join the conversation.

More
29 Apr 2016 00:42 #74040 by smgvbest
Replied by smgvbest on topic Lathe backplot reversed
This may be a dumb question, did you go into settings and change it from Turret to Manual Tool Change.
That was the first thing I changed and my tools show in front position'

Please Log in or Create an account to join the conversation.

More
29 Apr 2016 06:05 #74043 by mariusl
Replied by mariusl on topic Lathe backplot reversed
I did that and I changed the setting "GEOMETRY" to XZ it was -XZ. I still get tools displayed for front and back.
I am busy transferring my current lathe config to the PP machine. I will test this as soon as I have the setup done.

Regards
Marius


www.bluearccnc.com

Please Log in or Create an account to join the conversation.

More
29 Apr 2016 16:13 #74062 by cncbasher
Replied by cncbasher on topic Lathe backplot reversed
This is hard configured within the PathPilot GUI , if i am understanding you correctly
this is within the ui files , have you changed your files to use the lathe UI ?

Please Log in or Create an account to join the conversation.

More
30 Apr 2016 07:32 #74082 by mariusl
Replied by mariusl on topic Lathe backplot reversed
I am using the lathe config yes and I just made changes to the INI file and the the HAL files. I did not scratch in any code yet. I will avoid that if possible.

Regards
Marius


www.bluearccnc.com

Please Log in or Create an account to join the conversation.

Moderators: cncbasher
Time to create page: 0.112 seconds
Powered by Kunena Forum