Pathpilot Glade idiots guide

More
09 Dec 2020 18:54 #191517 by Vmax549
So have you been able to mod the PathPilot screen and then load it and it run OK ??

(;-) TP

Please Log in or Create an account to join the conversation.

More
17 Dec 2020 23:28 #192280 by Dorro1971
YES! YES! YES!

I just copied the XML file into the home folder opened terminal

sudo cp gtksourceview.xml /usr/share/glade/catalogs

and double clicked the glade file in python/images

now I can edit!

THANK YOU! gerritv

Please Log in or Create an account to join the conversation.

More
17 Dec 2020 23:31 #192284 by Dorro1971

Hi Folks,

Is there an idiots guide for Pathpilot with Glade?..

I have Pathpilot 2.4 installed and working I even managed to create a custom bitfile for my 7i92.

I'm just getting nosy and would like to poke around the GUI a little bit.

I have installed gtksourceview as it didn't seem to be part of the install but it looks like the gui was created with Glade 2.16.0 as it complains about the current version (3) and some widgets are deprecated when i analyse it.
I edited the source to change requirements to Glade3 but the deprecated widgets are still not present..
I also tried installing Glade 2.16.0 with some success but now gtksourcview catalogs are unavailable and the gui cannot be loaded.

I'm a little stuck from here and also pretty new to linux so any help would be great.

On the plus side, my lathe is fully functional have simulated a tool turret and with a little arduino work that will be my next project.

I have fitted Baumer MY-Com switches to the x and z axis and now homes perfectly to a micron or 3 every time.

Anyhow, thanks for a great forum..and any help ...

Dorro

Please Log in or Create an account to join the conversation.

More
18 Dec 2020 00:54 #192290 by Vmax549
I have gotten to that point many times now . I can open teh Screenfile just fine BUT it will NOT let me add a button or even move a button.

I just tried it again and it is still the same no editing.

(;-) TP

Please Log in or Create an account to join the conversation.

More
18 Dec 2020 19:57 #192371 by Dorro1971
I can move things a bit, but when i save it it restarts with missing components and pp goes into error...

i thought it was done, but still needs a bit of work.....at least it opens in glade, which is one step further.....

Please Log in or Create an account to join the conversation.

More
18 Dec 2020 23:09 #192405 by gerritv
Yes, I was tinkering some more today as well. gtksourceview is deleted from the glade file on save. I was hoping that running rip-environment.sh in ~/tmc would resolve that but there is something else not yet figured out.

I need to troll through this thread, I think: forum.linuxcnc.org/pathpilot/32168-playi...d-with-pathpilot-gui


Nothing is ever straightforward with Linux :-(
Gerrit

Please Log in or Create an account to join the conversation.

More
24 Dec 2020 22:03 - 24 Dec 2020 22:04 #193147 by gerritv
Just in time for Christmas I have figured it out.

The gtksourceview catalog file I posted earlier has to be copied into /usr/share/glade3/catalogs (/usr/share/glade is for Glade versions > 3.10 are are of no use to us). Then edit the file and replace gtksourceview-3 with gtksourceview-2 in 2 places near start of file.

Run glade-gtk2 (you should have installed that already of course) on the .glade file of your choosing and you should be golden. Note that just opening and saving the file will result in diffs, but they appear to be a matter of sequence of entries rather than actual differences.

Gerrit
Last edit: 24 Dec 2020 22:04 by gerritv.

Please Log in or Create an account to join the conversation.

More
17 Jan 2021 15:59 #195683 by gerritv
Just a reminder that in order for all this to work out in the end, you must install the gtksourceview2.0-dev package in order for Glade-gtk2 to find it when loading the PP glade files.

Gerrit

Please Log in or Create an account to join the conversation.

Moderators: cncbasher
Time to create page: 0.125 seconds
Powered by Kunena Forum