Help with Non Tormach PP v2.0 Spindle Control and Intermittent Loading Failure

More
06 Jul 2020 16:58 - 06 Jul 2020 17:19 #173762 by Mr. Technical
Hi,

I'm looking for some enlightenment. I have loaded PP on a router that was working before the switch.

I have been able to get PP (V2.0) to open and run (partially) after much hair-pulling.
I have adjusted the feeds and speeds, but am having trouble (days of it) with getting the spindle to operate.

Some background:
I am using a 5i25 and 7i76 board combo, and have loaded the 5i25_7i76x2.bit file correctly (I think).

I set the owner and permissions using CNCBasher’s info from his first tutorial:
“you will need to set the file permissions for the bit file
group 1002 & owner 1001
so : $ chgrp 1002 <path>/5i25_7i76x2.bit
&
$ chown 1001 <path>/5i25_7i76x2.bit”

This is a 0-10V drive VFD driven spindle that was working with the R6Probe.hal attached below, a 6125 and the same 7i76 board before the switch to PP and a 5i25 board. Different PCs.

I have commented out the PP version of spindle control and pasted in the section from the original R6Probe.hal.

Issues I’m having:
1) I can’t get the spindle to spin from the MDI line or using the FWD button and the RPM dialog box.

2) Every other time that I start PP up, it aborts and gives me this message in the log file:
“tormach_mill_mesa.hal:278: parameter or pin ‘hm2_5i25.0.7i76.0.0.spinout-minlim’ not found”
This makes me wonder if the bit file was loaded properly.

The next time it loads without aborting, allows me to reset, but then throws “Invalid S command of 750. RPM must be between 0 and 0 in the current belt position” error.

What is wrong with the syntax in the hal that prevents the spindle from spinning?
Why does it open PP one time, then not the next, then back to opening?

I'm running out of hair to pull out :-)
Attachments:
Last edit: 06 Jul 2020 17:19 by Mr. Technical. Reason: Clarification

Please Log in or Create an account to join the conversation.

More
08 Jul 2020 13:39 #173976 by Mr. Technical
No replies yet, so let’s break this into smaller bites.

Is there an example anywhere of a Hal for a 7i76 board being used in PP with a 0-10V setup for the spindle? Thanks,

Mr. Technical

Please Log in or Create an account to join the conversation.

More
More
08 Jul 2020 15:32 #173988 by Mr. Technical
Thanks Tommylight. I’ll start digging through the search results. It’s frustrating that I can’t use

halcmd show pin hm2_5i25.0.7i76

in PP 2.0. I’m used to that as a trouble shooting tool.

Please Log in or Create an account to join the conversation.

More
15 Jul 2020 22:38 #174775 by Mr. Technical
Thanks Tommylight. It’s good to have Halshow and halmeter back!

Strangely, it shows that the output pin I’m trying to turn on (hm2_5i25.0.7i76.0.0.output-01) is changing states in halmeter and halshow when I set it true with setp, but the voltage across it is not changing at all. It’s like the board is not getting the message or something.

Any ideas?
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
15 Jul 2020 23:06 #174776 by tommylight
Does the 7i76 have field power ?
Are you measuring the output in regard to the GND on the field power connector ?
Are you aware that output 01 is the second physical output pin on the connector ?

Please Log in or Create an account to join the conversation.

More
16 Jul 2020 00:16 - 16 Jul 2020 15:43 #174790 by Mr. Technical
All good questions.
1) 7I76 has field power (24VDC) on TB1

2) I'm measuring from bottom pin of TB1 (V+) to the affected output pin and measuring 17.7 VDC whether it is active or not.

3) Yes, I'm trying to change output 01, which is TB6 pin 18.

I should mention that it feels like a HAL issue, since I am not changing the wiring at all, just using a modified PP HAL and a different PC and 5i25. Switching back to the other PC and 6i25 board everything works.

I even put the 5i25 from PC2 in PC1, and it worked as it should with the original (non PP) HAL.
Last edit: 16 Jul 2020 15:43 by Mr. Technical. Reason: Mislabeled 24VDC pin

Please Log in or Create an account to join the conversation.

Moderators: cncbasher
Time to create page: 0.150 seconds
Powered by Kunena Forum