conv_s32_u32 problem

28 Jun 2021 05:57 #213093 by rafferty
Replied by rafferty on topic conv_s32_u32 problem
I used count=1 rather than name="" because I couldn't come up with a better name than conv_s32_u32. As you say If I had used a name it would have worked but I'm sure it would have got me eventually. 

I've read the bit in the manuals about x_y_z becoming x-y-z and so on and thought:

"Yeah, Yeah, I don't need to know that, it's just what halcompile creates so gcc doesn't fall over on funny variable names."

With a couple of seconds more thought I might have realised ... if gcc is compiling the modules with these modified names, then maybe these are the names that should be used.

Anyway I've got it now, thanks.



Please Log in or Create an account to join the conversation.

Moderators: cncbasher
Time to create page: 0.282 seconds
Powered by Kunena Forum