Disabling keyboard arrows moving the machine.

More
03 Jun 2023 13:18 #272818 by nick.smith
The arrow keys move the machine. 

I want to disable this.

I know how you can remap keys with xmodmap, but if I change the behavior of the arrows, I also lose desirable behavior in other apps. 

Importantly, I want to disable Up / Down arrows from moving in Y, but on the MDI line, I use up / down to scroll MDI history.

Does default LinuxCNC have this behavior?

Any ideas how to get rid of this "feature"?

Also, please note the question is how to remove this and not a discussion on why I want it removed. This is not a feature to me. It's a bug. 

Please Log in or Create an account to join the conversation.

More
03 Jun 2023 18:17 #272826 by JPL
This should work: forum.linuxcnc.org/38-general-linuxcnc-q...gging?start=20#62231

Then to solve the issue about shift+arrow keys go down 3 posts and add the lines from dgarrett post
 

Please Log in or Create an account to join the conversation.

More
03 Jun 2023 18:23 #272827 by JPL

... Importantly, I want to disable Up / Down arrows from moving in Y, but on the MDI line, I use up / down to scroll MDI history. ...

 

arghh ...  Originally missed that... Not so sure that the solution I've proposed will work for that.

Please Log in or Create an account to join the conversation.

More
03 Jun 2023 18:24 #272828 by nick.smith
I'll give it a shot and report back. There has to be a way to do it.

Please Log in or Create an account to join the conversation.

More
03 Jun 2023 22:22 #272842 by nick.smith
I've updated

\tmc\configs\tormach_mill\tormach_1100M.ini

with the required line and made unbind.py

No change. Is that the correct .ini file?

Please Log in or Create an account to join the conversation.

More
04 Jun 2023 15:01 #272882 by gerritv
At the top of that file you should see a warning that the file is replaced everytime that you run PP. Instead edit one of the .ini files listed at the top.

Please Log in or Create an account to join the conversation.

More
04 Jun 2023 15:30 #272883 by nick.smith
I did both. And saw the entry was maintained after reboot. But still didn't disable the keys.

Please Log in or Create an account to join the conversation.

Moderators: cncbasher
Time to create page: 0.113 seconds
Powered by Kunena Forum