PlasmaC install hung - Rpi4 with working LinuxCNC

More
14 Nov 2020 19:43 #189369 by kramerda
Hope this is the right spot for this
I have a working LinuxCNC 2.8 running on an Rpi4.
First try to run the python command to create a PlasmaC
config resulted in the following error page. I tried using both the original base
file name and creating a new file name. Both .ini and .hal file names checked
from base working Linuxcnc.I could really use some help
in interpreting this error - thank you.
Attachments:

Please Log in or Create an account to join the conversation.

More
14 Nov 2020 20:30 #189371 by kramerda
OK - sorry I fixed the above problem after I entered the full path names for the .ini and .hal on the create screen - now I'm getting "permission denied" error when I try to run the newly created .ini file per the documentation
back to learning more Linux to see whats wrong with my Rpi4 now - it runs the base linuxcnc OK ????

Please Log in or Create an account to join the conversation.

More
14 Nov 2020 21:00 #189375 by tommylight
Do you have spaces in the config folder name ?

Please Log in or Create an account to join the conversation.

More
14 Nov 2020 21:31 #189379 by snowgoer540

OK - sorry I fixed the above problem after I entered the full path names for the .ini and .hal on the create screen - now I'm getting "permission denied" error when I try to run the newly created .ini file per the documentation
back to learning more Linux to see whats wrong with my Rpi4 now - it runs the base linuxcnc OK ????


Do you need “sudo” in front of python?

Please Log in or Create an account to join the conversation.

More
14 Nov 2020 21:54 #189387 by tommylight

Do you need “sudo” in front of python?

Not that i can recall.

Please Log in or Create an account to join the conversation.

More
14 Nov 2020 23:05 #189402 by kramerda
no spaces but I do have an underscore _
I tried reset of linuxcnc then restart computer no help.
But now if I launch from Linuxcnc menu tree - it works fine.
And since I created a desktop icon no problems - we're good.
Since then I did have several errors that I manually corrected in the .hal file to get things to run.....
I had to comment out the lines for input and output pins that were created by pncconf that I chose for arc ok, float switch, and arc on.
I guess I missed something in my docs about not including these in the base machine. Once commented out of the .hal file then plasmac work on the Rpi4 - now for some tuning and testing
Thanks to all for a really great piece of real time control software!!!!
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
14 Nov 2020 23:09 #189404 by tommylight

I had to comment out the lines for input and output pins that were created by pncconf that I chose for arc ok, float switch, and arc on.
I guess I missed something in my docs about not including these in the base machine.

I always include them, then open the base hal file and copy/paste those pins into configurator and omit them. Much faster than typing them.
You are welcomed, always.

Please Log in or Create an account to join the conversation.

Time to create page: 0.097 seconds
Powered by Kunena Forum