preview missing something causing a error which stops the preview working

More
05 May 2020 03:31 #166722 by Becksvill
Hey guys

I have a funny issue here. I don't know much about probe basic really.

I have been getting this error.

photo


anyone know the problem?

regards

Andrew

Please Log in or Create an account to join the conversation.

More
05 May 2020 03:39 #166723 by KCJ
Hello Andrew,

You don't have an entry for tool 2 in your tool table. If you add the tool to your tool table it will go away.

This error was raised by the linuxcnc interpretor, not QtPyVCP, so it should have shown a message rather than raising an error dialog. I think you must be on an old version of QtPyVCP/ProbeBasic...

Cheers,
Kurt

Please Log in or Create an account to join the conversation.

More
05 May 2020 22:15 - 05 May 2020 22:16 #166805 by Becksvill
Hey kurt

that seems a little odd. this same tool table worked under axis. and then I manually change tools with g code in the mdi tab it changed to tool 2 fine.

and this problem was not isolated to tool 2 all the tools did it. but only if they were currently loaded and then the program called the same tool. eg if T3 was loaded in spindle and I called up T2 in my program the machine came up with the Hal manual toolchange button and I changed the tool and it worked fine. But If I had T2 loaded in spindle and then ran the program it gave the error. Linuxcnc would still run I discovered by pushing cycle start after ignoring the errors but there was no preview.

I felt like I was back on a old machine drip feeding lol pretty funny actually how scared I felt when I didn't have that preview lol.

just to be clear I have attached my tool table that is currently on the machine.

a friend suggested that I should delete all the tools and then remake them in probe basic and that is what I am trying to do now. I will let you know how that goes.

ps I have just installed the latest probe basic development install 10 days ago. this should be as up to date as you can get I hope.
Attachments:
Last edit: 05 May 2020 22:16 by Becksvill. Reason: forgot to say something

Please Log in or Create an account to join the conversation.

Moderators: KCJLcvette
Time to create page: 0.078 seconds
Powered by Kunena Forum