editvcp probe basic - Error

More
06 Jan 2022 02:44 #230923 by Donb9261
don@don-Debian:~$ editvcp probe_basic
Loading YAML config file: /home/don/probe_basic/probe_basic/probe_basic.yml
Loading UI file: /home/don/probe_basic/probe_basic/probe_basic.ui
Loading QSS file: /home/don/probe_basic/probe_basic/probe_basic.qss

Starting QtDesigner ...
ERROR: It appears QtDesigner is trying to load the QtPyVCP widgets
using a python version greater than 2.7, this is not supported.
Make sure that you have the correct version of the libpyqt5.so
file in /usr/lib/x86_64-linux-gnu/qt5/plugins/designer/, see the
Installation Trouble Shooting section of the QtPyVCP Documents for more info.

Also, I am having issues simply starting the Probe Basic config in LCNC. Getting an error:

Debug file information:
Note: Using POSIX realtime
motion.c: Creating unlock hal pins for joint 4
Traceback (most recent call last):
File "/home/don/.local/bin/probe_basic", line 33, in <module>
sys.exit(load_entry_point('probe-basic', 'gui_scripts', 'probe_basic')())
File "/home/don/probe_basic/probe_basic/__init__.py", line 16, in main
opts = parse_opts(vcp_cmd='probe_basic',
File "/home/don/.local/lib/python3.9/site-packages/qtpyvcp/utilities/opt_parser.py", line 104, in parse_opts
opts = DotDict({arg.strip('-<>').replace('-', '_') : convType(value) for arg, value in raw_args.items()})
File "/home/don/.local/lib/python3.9/site-packages/qtpyvcp/utilities/opt_parser.py", line 104, in <dictcomp>
opts = DotDict({arg.strip('-<>').replace('-', '_') : convType(value) for arg, value in raw_args.items()})
File "/home/don/.local/lib/python3.9/site-packages/qtpyvcp/utilities/opt_parser.py", line 65, in convType
if isinstance(val, basestring):
NameError: name 'basestring' is not defined

Any help is appreciated.

Btw... Installed Probe Basic via the installer using the dev install.

Please Log in or Create an account to join the conversation.

More
06 Jan 2022 02:51 #230924 by Donb9261
I do believe this is the issue. But not positive.

Happens when installing the compiled files for probe basic.

Installing collected packages: qtpyvcp, probe-basic
Attempting uninstall: qtpyvcp
Found existing installation: qtpyvcp python3-master-144.g82f25ff8
Uninstalling qtpyvcp-python3-master-144.g82f25ff8:
Successfully uninstalled qtpyvcp-python3-master-144.g82f25ff8
Running setup.py develop for probe-basic
Successfully installed probe-basic qtpyvcp-0.3.19

Because now none my VCP's will load and get the same error when launching LCNC. NameError: name 'basestring' is not defined

Please Log in or Create an account to join the conversation.

More
06 Jan 2022 03:30 #230925 by Donb9261
Yep...

That is the issue.... Probe Basic uses 0.3.19 and not master.

ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
probe-basic 0.4.0+7.g5813f91 requires qtpyvcp>=0.3.9, but you have qtpyvcp python3-master-146.g1ff9e4e9 which is incompatible.

Please Log in or Create an account to join the conversation.

More
06 Jan 2022 03:37 #230926 by Donb9261
Here is a screen shot of a basic vcp working now that I replaced the qtpyvcp distro 0.3.19 with master

    
Attachments:

Please Log in or Create an account to join the conversation.

More
16 Feb 2022 03:22 #235006 by kenwoodhf
I have the same error. you said
That is the issue.... Probe Basic uses 0.3.19 and not master.

ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
probe-basic 0.4.0+7.g5813f91 requires qtpyvcp>=0.3.9, but you have qtpyvcp python3-master-146.g1ff9e4e9 which is incompatible.

I am fairly new to linux and I was hoping you could explain how to install qtpyvcp 0.3.9.
Thanks
Jan

Please Log in or Create an account to join the conversation.

More
17 Feb 2022 21:57 #235183 by Donb9261
Although I wish I could help, I am running Debian 11 Bullseye with Python 3.10. Probe Basic has a few issues with that version and will not work with the required master QtPyVCP for DEV install. You can however install the stable non-master version with Probe basic on Debian 9 or Mint 19. Regardless, I am sure Kurt is working the issue on Probe Basic and will have it fixed soon enough. 

If you really want to get you feet wet I would do a Debian 11 Bullseye dev install. The instructions are at qtpyvcp.com under install for Debian 11 Bullseye. Do exactly as it says and it works flawlessly with no need for other packages. I suggest using a non-free driver install which if you google Debian 11 non-free will link you to the downloads. I suggest using the Cinnamon non-free ISO for live usb. Once the PC boots simply locate the install Debian 11 icon on the desktop and follow the prompts. Then go to the qtpyvcp.com website and follow the instructions verbatim. Takes about 30~45 minutes depending on your PC speed. 

Hope that helps. 

Sincerely,

Don
The following user(s) said Thank You: rodw

Please Log in or Create an account to join the conversation.

Moderators: KCJLcvette
Time to create page: 0.132 seconds
Powered by Kunena Forum