QtPyVCP designer plugin fails

23 Sep 2022 16:50 #252627 by charleyann
I have my new development machine installed and running Debian bookworm.
Linuxcnc was installed using apt install and is running without issues.
I also installed QtPyVCP and Probe Basic.

When I run the Qt Designer or edit probe basic the libpyqt5.so plugin fails to load. It's looking for libpython3.9.so.1.0 which is not installed.
Instead, libpython3.10.so.1.0 is installed in /usr/lib/x86_64-linux-gnu

I tried setting up a symlink to libpython3.9.so.1.0. That got rid of the load error but the widgets still won't load and I can't get at any rules.
How do I point the plugin to libpython3.10.so.1.0???

qtpyvcp --info      

   QtPyVCP Info
       Version:        python3_master+291.gb701875d

   LinuxCNC Info
       Version:        2.9.0~pre0

   Qt Info
       Qt Version:     5.15.4
       Qt API:         PyQt5
       Qt API Version: 5.15.7

   System Info
       Description:    Debian GNU/Linux bookworm/sid

       Kernel:         5.19.0-1-rt-amd64
       Version:        #1 SMP PREEMPT_RT Debian 5.19.6-1 (2022-09-01)
       Ram:            63 GB

   CPU Info
       Vendor ID:      AMD Ryzen 7 5800X 8-Core Processor
       Physical Cores: 8
       Logical Cores:  16

       Hostname:       char2
       IP Address:
       MAC Address:    d8:5e:d3:86:47:96

The following user(s) said Thank You: TurBoss

Please Log in or Create an account to join the conversation.

23 Sep 2022 19:26 - 06 Oct 2022 20:15 #252632 by TurBoss

I could only manage to use python 3.10 by building linuxcnc from sources, www.linuxcnc.org/docs/devel/html/code/building-linuxcnc.html
using run in place (RIP) but debs should work also

I'm installing a debian 12 virtual machine and see

EDIT: this was totally unrelated i think i messed topics :|

I took libpyqt5.so for python 3.10 and now should up at github

thanks and sorry
Last edit: 06 Oct 2022 20:15 by TurBoss.

Please Log in or Create an account to join the conversation.

Moderators: KCJLcvette
Time to create page: 0.314 seconds
Powered by Kunena Forum