PyQt5 Ubuntu 20

More
07 May 2021 12:26 #208209 by prochj51
PyQt5 Ubuntu 20 was created by prochj51
Hi guys,

has any of you successfully installed PyQt5 to get qtvcp working on Ubuntu 20?

I guess there are obstacles when I found this thread related to Mint 20
https://forum.linuxcnc.org/qtvcp/40213-can-t-get-linuxcnc-to-start-with-qtdragon

Is there any improvement in this matter.

Thank you for answer
Jiri

Please Log in or Create an account to join the conversation.

More
07 May 2021 13:18 #208215 by cmorley
Replied by cmorley on topic PyQt5 Ubuntu 20
Mint 20 requires linuxcnc to be compiled with python3 support.
I haven't tried Ubuntu 20.04 but since mint 20 is based on it - it might also require it.
Python 3 support I would call experimental yet.

Please Log in or Create an account to join the conversation.

More
07 May 2021 14:03 #208217 by tommylight
Replied by tommylight on topic PyQt5 Ubuntu 20
I did have a successful install when 20 was beta aaaand never again, once i had about 6 versions of Python installed and it still did not work! Gave up and moved back to 19.3.

Please Log in or Create an account to join the conversation.

More
07 May 2021 16:00 #208228 by prochj51
Replied by prochj51 on topic PyQt5 Ubuntu 20
Alright, thanks. I guess I will also step down to previous version.

Please Log in or Create an account to join the conversation.

Moderators: cmorley
Time to create page: 0.130 seconds
Powered by Kunena Forum