Displaying pictures on buttons

More
01 Jan 2022 19:18 #230467 by daiman444
Hello. I cannot figure out the problem of displaying pictures attached to ActionButtons. These pictures are displayed or not. how to do it correctly so that the pictures are guaranteed to be displayed?
 
This is what the interface looks like in QtDesigner:
 

This is what it looks like after loading the configuration
 

 
Attachments:

Please Log in or Create an account to join the conversation.

More
01 Jan 2022 20:41 #230481 by cmorley
is this
../../../Рабочий стол/test/img/zoomplus.png
really the path name?

<normaloff>../../../Рабочий стол/test/img/zoomplus.png</normaloff>../../../Рабочий стол/test/img/zoomplus.png</iconset>

Please Log in or Create an account to join the conversation.

More
02 Jan 2022 05:45 #230530 by daiman444
Greetings. relative path to image files: ./img. Full path to image files: /home/ddd/linuxcnc/configs/test/img/

Please Log in or Create an account to join the conversation.

More
02 Jan 2022 06:09 #230531 by cmorley
Well it looks like something went wrong as thats a pretty odd looking path.
Try editing the file to the right path and see what happens.
Make a back up though

Please Log in or Create an account to join the conversation.

More
02 Jan 2022 07:06 #230533 by daiman444
I attach an archive with a config. maybe someone will be able to suggest the right direction to find a solution to the problem
Attachments:

Please Log in or Create an account to join the conversation.

More
02 Jan 2022 12:50 #230544 by hottabich
Open any file with F12. qss or create your resource and style files. Take a close look at how this is done in qt_axis.
Attachments:

Please Log in or Create an account to join the conversation.

More
02 Jan 2022 13:02 #230545 by daiman444
Именно на примере qt_axis и пытаюсь разбираться. Скопировал кнопки которые не теряют картинки и переназначил на них действия и картинки. Вроде все запускается и не теряется

Please Log in or Create an account to join the conversation.

Moderators: cmorley
Time to create page: 0.131 seconds
Powered by Kunena Forum