2.8 5axiskins bug?

More
19 May 2020 17:37 #168287 by AndrewL
2.8 5axiskins bug? was created by AndrewL
In the current version of 2.8 (linuxcnc-uspace-dev 1:2.8.0~pre1.5880.gef6ad1a), if I use the LinuxCNC Configuration Selector, LinuxCNC/SIM/SIM/axis/vismach/5axis/bridgemill/5axis
to test the 5axiskins, I jog B, then attempt to jog C, but the machine will not rotate around the tool as expected.

If I do the same procedure in 2.7 (linuxcnc-uspace-dev 1:2.7.15.8.gf38f9c), the machine rotates around the tool.

Can anyone else confirm that this is a bug?

Please Log in or Create an account to join the conversation.

More
23 May 2020 08:58 #168666 by bbsr_5a
Replied by bbsr_5a on topic 2.8 5axiskins bug?
i dont see a bug in the movement
what are you expecting
the new interpreter from 2.8 dont like the INI format as it is not straight
here is a better ini to the Machine more speed and presetup
Attachments:

Please Log in or Create an account to join the conversation.

More
01 Jun 2020 12:20 #169660 by AndrewL
Replied by AndrewL on topic 2.8 5axiskins bug?
Thank you for your reply. I used your config without success on my computer. I've tried uninstalling and reinstalling linuxcnc. I've also tried on multiple computers. Prior to noticing this problem, I had been attempting to halcompile a switchkins config and had been experimenting with the locked rotary axis feature. Could this be the cause?

Please Log in or Create an account to join the conversation.

Time to create page: 0.074 seconds
Powered by Kunena Forum